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Welcome

What is the F60-t used for?
The F60 is a family of thin-film mapping tools that offer the user a low cost and easy to use platform for
stand-alone thin-film thickness and n and kmeasurement for a range of applications. Thin-film thickness
and n and k aremapped quickly and easily with the F60 advanced spectral reflectance system. The
motorized R-Θ stagemoves automatically to the selected measurement points and provides thickness
measurements in seconds. The F60 can be used for high throughput measurements for process
development and production monitoring.

Warning:Accurate measurements require suitable recipe settings and a valid baseline. Improper system setup or
an aged lamp may also lead to errors. It is the user’s responsibility to ensure that this instrument is being used
properly for its intended purpose. Please contact Filmetrics support for assistance with any questions.
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Safety, Maintenance, and Care

This symbol indicates information or instructions that must be read and carefully followed to prevent
hazards, injury to the operator, or damage to the instrument.

This symbol indicates a potential shock hazard. Areas marked with this symbol should be serviced by a
trained service technician.

This symbol indicates that the product conforms to theWEEE (Waste in Electrical and Electronic
Equipment) Directive 2002/96/EC.

This symbol indicates that the product meets the applicable EU safety, health and environmental
protection directive requirements.

This label indicates theModel Number and Serial Number of the instrument. This information may be
necessary when contacting Filmetrics for assistance.
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Disclaimer: Use of this instrument in a manner inconsistent with the information and directions included
in this manual may impair the protections designed into the product resulting in danger to the operator
or damage to the instrument

Installation Location:When deciding on a location for the instrument, ensure that the instrument is
installed in a well-ventilated location. Enclosing the unit, or blocking the vent holes, may impair the
performance of the instrument or damage the internal components.

Cleaning: The need for periodic cleaning of the system is based on the cleanliness of the environment in
which the system is installed. Only the external surfaces are to be cleaned. Cleaning and maintenance of
all internal components is to be performed by a trained service technician. Do not use aerosol, or spray,
cleaners as they may contaminate the sensitive optical surfaces on the instrument.

Before performing any service on the instrument ensure that themain power is disconnected.

Cleanroom, or low lint, wipes should be used to wipe down the system. Amixture of Isopropyl Alcohol
(IPA) and De-ionized Water (DI H2O) at 70%DI H2O: 30% IPA is to be used for cleaning. Undiluted IPAmay
be used, if the 70:30 DI and IPAmixture is not available, but extra caremust be taken. Avoid using
stronger solvents, such as acetone, as thesemay compromise the surface finish.

Avoid excessive pressure on any surface when cleaning. Excessive forcemay bend a component, which
would damage the system, or cause the system to be out of alignment.

Start with the top of the system and work down. Use slowmotions, in a straight line, from the back to
the front of the surface being cleaned. Change the cleaning wipe periodically to avoid re-depositing
material back onto the surface being cleaned. Allow all cleaned surfaces to dry completely before
restoring power to the system.
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CE Mandated Warnings

Please read the following instructions carefully to prevent potential shock or fire hazards. This manual
should be retained for future use

Bitte lesen Sie die nachstehende Anleitung sorgfältig durch, um Stromschlag und Feuergefahr zu
vermeiden. Diese Betriebsanleitung soll für späteren Gebrauch sorgfältig aufbewahrt werden.

Preghiamo di leggere accuratamente, le sequenti Instruzioni, per evitare Prossiomi Incendi e Correnti.

Shock Hazard - Do Not Enter
Achtung Hochspannung - Nicht Berühren

Attenzione Corrent-Forte - Prego non toccare

The power cord should be removed after use.
Das Stromkabel soll nach Gebrauch aus dem Gerät herausgezogen werden.

La Corrente viene.

Never expose the unit to water or liquids. Avoid direct sun.
Bringe das Gerät nicht mit Wasser oder anderen Flüssigkeiten in Berührung. Vermeide direkte

Sonneneinstrahlung.
Evitare contatto con acqua oppure liquidi Infiammabili al Macchineggio. Auche entrate di Sole.
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Do not insert any objects into the unit.
Keinen Gegenstand in das Gerät einbringen. Do non inseriamo any obietta into gli unità.

Non mettere ogetti dentro la Macchina.

Do not use near open flame or heat.
Das Gerät nicht in der Nähe einer offenen Flamme oder Hitze benutzen.

Non mettere la Macchina vicino a fuochi oppure Riscaldamenti.

The unit should never be enclosed or blocked.
Das Gerät darf nicht eingeschlossen oder blockiert werden.

La Macchina non chinderla per nessun motivo.

Connect unit only to a properly measured supply. Use only the which is provided with the unit.
Schließen Sie das Gerät nur an eine ordnungsgemäss vermessene Stromsversorgung an. Verwenden Sie

nur ein , wie es auch mit dem Gerät ausgeliefert wird.
Montare solo con misura normata. Adoperando solo cosi come e fornita la

Macchina.
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1. Software Overview
The way that light reflects off a thin film is determined by the characteristics of the film, such as its
thickness, optical constants, and roughness. The F60 is able to determine thin-film characteristics by first
carefully measuring the amount of light reflected from the thin film over a range of wavelengths (i.e., by
measuring the reflectance spectrum). It then analyzes this data by comparing it to a series of calculated
reflectance spectra. Most of the features of the FILMapper software that runs the F60 can be divided into
reflectance acquisition and reflectance analysis functions. The following pages outline themain features
of the FILMapper software.

TheWafer Map Tab is used to initiate mapping and to display measurement results. Themap
configuration and the film properties to bemapped are specified in the Edit Recipe > Wafer Map dialog
box.
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1.1 The Wafer Map Tab

1. Standard Windows menus, including; File, Edit, Setup, Acquire, and Help.

2. These tabs are used to select between theWafer Map,Measure, and Historywindows.

3. Information about the Operator can be entered here for tracking purposes. Sample information is
automatically determined when the wafer map is saved.

4. This section is used to determine how themap is displayed. The Replot button must be clicked to
enact any changes selected.

i. Parameters to Display: Allows the user to select which parameter (thickness, index, roughness,
etc.) to display on themap.
ii. 2D/3D: Allows the user to select between two dimensional and three dimensional maps.
iii. Show Color: Enables or disables the color bar on the left hand side of themap.
iv. Show Points: Enables or disables displaying themeasured points on themap.
v. Show Values: Enables or disables displaying the
vi.Manual Color: Allows the user to input a manually selected color scale.

5. Statistical analysis for the set ofmeasurements taken.
i.Minimum parameter value recorded for selected wafer, xmin.
ii.Maximum parameter value recorded for selected wafer, xmax.
iii.Mean (average) parameter value of all measurement locations, .
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iv. Std.Dev. (Standard Deviation), or 1σ, is calculated using the following equation:
where is themean and n is the number ofmeasurements.
v. Uniformity as a percentage. The equation used in the uniformity calculation is determined under
Setup > Options > Map.
vi. CTE is the center to edge thickness variation calculated using a least squares linear fit of the
average thickness of 10 radial regions. If the CTE is positive (> 0), then the thickness is greater
around the wafer edge. If the CTE is negative (< 0), then the thickness is greater near the center of
the wafer.
vii. TheWedge value is the product of the slope at the angle specified by theWedge Angle and the
sample diameter (for rectangular samples the length of the longest edge is used in place of
diameter).
viii. The direction ofmaximum positive slope (increasing measured values) is given by theWedge
Anglewhere x=1, y=0 is 0° (3 o’clock) and x=0, y=1 is 90° (12 o’clock).
ix. Valid indicates howmany locations have valid results out of the total number ofmeasurement
locations.

6. These options control the wafer map process.
i. Start or Restart themapping cycle.
ii. Stop themapping cycle.
iii. New clears themeasurement results and displays the points to bemeasured as determined by
the settings in Edit Recipe > Wafer Map tab.
iv. Go To to a specified location on the wafer.
v. Baseline begins the baselining sequence.
vi. Used to select saved recipes.
vii. Opens the Edit Recipewindow.

7. Graphical display of the wafer with points ofmeasurement as well as a color scale for thickness
summary. The top of the image is the edge closest to the stagemirrors.
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1.2 The Measure Tab

1. Standard Windows menus, including; File, Edit, Setup, Acquire, and Help.

2. These tabs are used to select between theWafer Map,Measure, and Historywindows.

3. Information about theOperator and Sample can be entered here for tracking purposes.

4. Displays the thickness of the film being solved for, as well as whether a sample is good or bad based on
the settings selected in the Alarms tab.

5.Measure a sample, Baseline the system, or Analyze an already opened spectrum. If theMeasure
button is grayed out, the system will require a baseline before further measurements may be taken.

6. Select saved recipes from the drop-down list, or open the Edit Recipe dialog box.

7. Details about the calculated thickness, as well as any additional parameters that were solved for,
including Roughness, n and k, and Nonuniformity, and theGoodness of Fit (GOF) are displayed here.

8. Graphical display for spectra. A click of the right mouse button while the cursor is within the graphical
display opens themenu below for easy reading of cursor values in theMeasure Tab. Use the keyboard
up/down and right/left arrows to move themarker to a desired location.
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The graph limits can be changed by double-clicking on the graph display. The text boxes along the
bottom of the graph control the wavelength range, in nanometers, displayed on the screen. The two on
the left represent the Reflectance (%) range, with themax being set in the upper box and themin being
set in the lower. The boxes on the right are for Transmittance (%). Check the Auto checkbox to activate y-
axis autoscaling. The lower value is always 0 for autoscaling; themaximum y-axis upper limit is 5000. The
axes can be set to display in percent or as a decimal value (100% = 1).

Graph Options can be accessed and edited by double-clicking on the main graph window.
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1.3 Go To

TheGo To function allows the user to manually locate the system in the x, y, and, with capable systems,
the z direction. Measurements may be entered as discrete coordinates, or by clicking on the arrow keys
to move the stage accordingly. When using the arrow controls, the inner buttons allow a slower
movement speed, while the outer buttons are for faster motion.
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1.4 The History Tab

1. Standard Windows menus, including; File, Edit, Setup, Acquire, and Help.

2. These tabs are used to select between the and Historywindows.

3. Used to alternate between the Single Measurement andMeasurement Trend tab. Selecting the
Measurement Trend tab will allow the user to see a plot of themeasurement results versus
measurement number. A drop-down list allows the user to select between which parameter is graphed.
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When the Measurement Trend tab is selected in the Historywindow, the right side of the screens graphs the
results.

4. Shows themeasurement results for the selected spectrum (must be in Single Measurementmode).

5. Displays the selected spectrum (in Single Measurementmode).

6. Displays statistics for all measurements included in the history file.

7. This list contains all spectra currently included in the history file. Left clicking on a column header will
re-sort the data in ascending or descending order based on the selected column. Right clicking anywhere
is this box will allow the user to open the Edit Columns control panel.



16

1.5 The Edit Recipe Window

The Edit Recipewindow is used to define the film stack and to set analysis and acquisition parameters.

1. These buttons allow you to, in order from left to right:
i. Open a saved recipe.
ii. Start a new recipe.
iii. Save the current settings.
iv. Save the current settings as a new recipe
v. Delete the current recipe.

2. Opens a drop-down list for quick access to saved recipes.

3. Author, as defined by user login name and recipemodification date is indicated here.

4. Allows the user to select between the Film Stack, Analysis Options, Alarms, Wafer Map, and tabs.
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5. The desired thickness units are chosen here. The choices include angstroms (Å, 10^-10m), nanometers
(nm, 10^-9m), kilo-angstroms (kÅ, 10^-7m), microns (µm, 10^-6m), microinches, mils, millimeters (mm,
10^-3m), and Custom Units.

6. This is where thematerials and parameters to be solved are defined.
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1.6 Menu Controls

This section describes the various functions available through the standard Windows FileMenus.

File Menu

Edit Menu

Setup Menu

Acquire Menu

Help Menu

1.6.1 File Menu

Open Spectrum… (Measure Tab only)
This command is used to open stored reflectance spectra, which are then displayed and can be analyzed
for film properties.

Open History…
Previously saved History data containing measurements and statistics can be loaded with this
command.

Import: Recipe…
To import recipes that were previously exported, or created with an older version of FILMapper, use this
command.
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Import: Material…
Custom materials, either created by the user or provided by Filmetrics, can be imported using this
command.

Import: License…
When the user purchases an upgrade for the system, Filmetrics will send a license file to the user. The
licensemust be imported into the software before upgrades are effective.

Save Measured Spectrum… (Measure Tab only)
This command is used to save spectra for export or later analysis. All data is saved along with the
corresponding wavelength data in comma-delimited format. Files can be saved in four different formats:

*.fmspe: This file can only be opened in FILMapper 5.0 or greater and is the preferred way to save
spectra. Additional information from data acquisition is stored in this file.

*.spe: This file can be opened in all versions of FILMapper.

*.csv: This is a comma-delimited file that can be opened directly in Excel.

*.txt: This is a tab-delimited file, and can be opened with a text editor.

Save Screen to File… (Measure Tab only)
This command takes a screenshot of the FILMapper window.

Export: Recipe…
Recipes can be exported for use on other computers running FILMapper. The exported file will also
automatically include any material files required by the recipe. To duplicate an analysis, all that is needed
is the exported recipe and the spectrum being analyzed.

Export: Recipe for FILMapper 4…
This command will convert a recipe for use with FILMapper 4. This will not includematerial files or recipe
features only available in FILMapper 7.

Export: SystemInfo File…
For certain upgrade purchases that can be done through software, the user will be required to send the
SystemInfo file to Filmetrics, which can be exported using this command.

1.6.2 Edit Menu

This menu allows access to theMaterial Library, as well as theMap Pattern editor.
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Material Library
Thematerial library is used to display information about existing materials as well as create new ones.
Material files shipped with FILMapper have the file extension “.fibnk” and will only display limited
information. User created material files, ".fitnk", can be plotted on a graph or viewed in table form.

A newmaterial may be entered into thematerial library manually if refractive index (n) and extinction
coefficient (k) are known as a function of wavelength for the newmaterial.

To create a newmaterial file:

1. Select Edit > Material Library…menu item. The Edit Material dialog box will appear.

2. Click New… to create a newmaterial.

3. Select the type ofmaterial you are ready to create (Dielectric, Photoresist, Semiconductor, Metal,
or Other).

4. Optimize the functionality of the file by entering index values over the entire wavelength range of
the system. The wavelength unit is nanometers. Enter index information every 20 to 50 nm,
depending on the complexity of the data. In areas where n or k is quickly changing, more densely
spaced points should be entered.
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5. Alternatively, select theModel > Custom radio button and click theDetails button. A Custom
Model Information dialog box will appear. Select the appropriatemodel. Enter in the known
coefficients and click OK. Cauchy coefficients are displayed in microns. If they are entered in Å,
FILMapper will automatically detect this and convert them to microns.

6. Click the save button to save thematerial. You will be asked for a file name, and you may select
one of two file types:
*.fitnk: Creates a unified file with both n and k information. Compatible with FILMapper 6 and
beyond.
*.nnn: Creates a *.nnn file and, if there is k in thematerial, a *.kkk file to contain material data. For
files with both n and k, the two files must have the same filename, for example xmaterial.nnn and
xmaterial.kkk , in order for FILMapper to properly indentify them. Compatible with all versions of
FILMapper.
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Map Pattern…(Wafer Map tab only)

The Edit Map Pattern dialog allows the user to specify themeasurement pattern on the wafer. Patterns
can be generated automatically through the dialog, or pre-existing patterns can be opened or imported
for review.

When generating patterns automatically, the user must first determine if the wafer shape is round or
rectangular under theWafer Type option. The pattern type specifies the pattern geometry within the
wafer shape. With Round selected, the user can enter the expected wafer diameter into the Round Info
text box at the bottom of the dialog window. If Rectangular is selected, the Rectangle Infowill allow the
input of both height and width data of the sample. All measurements are assumed to be in millimeters.
FILMapper is able to automatically scale the wafer map to match other wafer sizes if a different wafer size
is input during recipe creation in the Edit Recipe > Wafer Map dialog.
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The pattern density and central exclusion features specify the exact distribution of themeasurement
points on the wafer. A greater density leads to an increased number ofmeasurement spots, and can only
be increased in whole numbers. Central Exclusion can be used when the user doesn't want a point in the
exact center of the wafer. The exclusion must be <1 in order to function properly. The Radial Pattern
 Details options are only enabled when the type is set to Radial. Enabling theManual Spots per
Quadrant option will allow the user to modify the number ofmeasurement spots even further by
increasing the number of spots per each concentric ring.

Rectangular patterns allow the user to modify spot density, or with the addition Fixed option allows the
user to manually enter the number of spots per each row and column.

Linear patterns by default are set to measure from Center to Edge, but can be set to Edge to Edge using
the Linear Pattern Details options.

An updated version of themap pattern can be displayed by clicking Redraw after changing any of the
above values. Save as will save the newmap pattern in the FILMapper\Patterns\Custom folder under a
user determined name.

If the x-y coordinates for a specific pattern are known, the FILMapper software can recognize a text file of
these coordinates. See Editing Map Files Using Excel for more details on creating custom maps.

All custom patterns must be saved in FILMapper\Patterns\Custom folder. To select the new pattern in the
Edit Recipe>Wafer Map tab, select the Custom Coordinate System and the name of the pattern from
the drop-down box.

1.6.3 Setup Menu

This menu contains the settings for manually obtaining the Standard/Background information, Display
options and the Raw Signal dialog. This is also where user access can be set through the Access Control
option, as well as modifying some system Options.

Standard/Background
This control is used when manually taking and enabling/disabling the Reflectance Standard and
Background compensation.
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Take Standard
This button allows the reflectance standard portion of the baselinemeasurement to be taken without
having to re-take the background measurement.

Take Background
This button allows the background portion of the baselinemeasurement to be taken without having to
re-take the referencemeasurement.

Use Standard
This checkbox allows the reflectance standard portion of the baseline correction to be enabled or
disabled. This box is only available if a baseline has already been completed.

Subtract Background
This checkbox allows the background subtraction portion of the baseline correction to be enabled or
disabled. This box is only available if a baseline has already been completed.
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Display

Color Measurement Settings: Color Space
The color of a spectrum can be displayed and quantified on themain screen if a color space coordinate
system is selected.

When a Color Space is selected, the color of the spectrum and the coordinates appear on the Measure Tab.

Color Measurement Settings: Observer
When a specific color space is chosen for display, this option allows the user to choose between the CIE
1931 2 degree observer and the CIE 1964 10 degree observer. Note that this variable is associated with
the CIE eye-response convention (see, for example, http://en.wikipedia.org/wiki/CIE_1931_color_
space) and is unrelated to the illumination or collection angle of themeasurement.

Color Measurement Settings: Illuminant
This setting refers to the standard illuminant being used by the software to help determine the results of
the color analysis.

Color Measurement Settings: Fixed Luminance
The user can fix the luminance of the displayed color. Since antireflective coatings, for example, are
inherently transmitting, the spectra have very little luminance and the coating color may appear black on
the screen. Adjusting the luminance does not affect the color space coordinate results.



26

Spectrum colors of the same spectrum with fixed luminance of 10%, 40%, and 70%, respectively.

Number of Spectra
This sets themaximum number of spectra (up to 10) displayed simultaneously on themain FILMapper
screen. If themaximum number of spectra is reduced to fewer than the number already on the screen,
themost recently selected spectra will remain.

Spectra Transformation
For spectra with both reflectance and transmittance information present, you can have the software
display them as separate spectra (none), added together (sum), or the absorptance (1-R-T).

Graph Options
The background of the graph can be set to white or black using this option, as well as allowing the
software to auto-position the legend box to avoid or minimize overlap with the displayed spectra.

Measurement Results: Significant Digits
The user can select the number of significant figures, from 1 to 7, that the results are displayed in. For
example, with the units set to Angstroms and 4 significant digits, The software would report a thickness
of 7213 Å. If significant digits is switched to 3, it will instead display the thickness as 7210 Å.

Displayed Controls
These checkboxes are used to determine which controls are shown on the right hand side of the
FILMapper window.

Access Control
FILMapper incorporates password protection to limit access to themeasurement software and settings.
When the software is initially installed, access control is turned off. The software will automatically boot
up with Engineer level access that enables access to all features of the program except turning on and off
access control and adding and deleting users.
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Turning on access control requires Supervisor level access. The software is delivered with one user, a
supervisor, in the list of authorized users as shown below:

UserID: filmsuper

Password: filmetricsfff

To turn on access control, log in as filmsuper using the password shown above. The Activate Access
Control checkbox should selected, enabling access control functions. User ID and Password are case-
sensitive.

To add an operator level user, select operator from the Access Level list box, type a user name and type
an initial password for that user. Then click the Add User button. To add an engineer or a supervisor user
follow the same procedure, but pick the appropriate access level from the list box before pressing the
Add User button.

To delete a user, enter theUserID and press theDelete User button.

Operator and Engineer level users can change their passwords when they are logged in by entering their
password into the password box and pressing the change button. Supervisor-level users can change
their password or the password of any other user by selecting the appropriate access level, entering the
appropriateUserID and the new password and pressing Add User. If the program finds that a user
already exists, it will delete the old entry for that user and create a new entry.

We recommend that you create a new supervisor level user and delete the filmsuper user for maximum
security. If all supervisor level users forget their passwords, it will be necessary to re-install the software
and add all the users again.
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Raw Signal

Raw Signal
The Raw Signal dialog box allows the user to plot the raw (no baseline corrections applied) spectrometer
signal on themain graph. This is useful when setting integration times manually.

Integration
The user can set the integration time and the number of integration cycles for the spectrometer.
Increasing cycles can be used to help smooth the data being returned to FILMapper. Clicking Update
Recipe transfers the listed integration time and cycles to the current recipe.

Signal Corrections.
Spectrum Preprocessing allows the user to apply a smoothing function to the displayed spectra. See
here for more details.

Start/Stop
This button starts/stops the acquisition of the spectrometer signal.

Graph Limits
This allows the user to either manually set or autoscale the graph limits. Click Apply after any changes to
display them on themain FILMapper window.

Options
TheOptionsmenu allows the user to enable, disable, or modify several different settings within
FILMapper.

General Settings

Wafer Map

Data Recording
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General Settings

TheGeneral Settings tab is used to enable, disable, and modify various options in the software. Baseline
 Reminder allows the user to set an interval at which the system will alert them to re-baseline the system.
It is set at one hour by default. The Selected Camera pull down menu allows the user to enable the
Sample Cam on equipped systems, or choose between different cameras if there is more than one
connected to the computer. The Reference Signal Thresholds options are used by the software during
the process. If, during the Acquire Reference step of the Baseline, the intensity of the reflectance
standard goes above or below the percentages listed an error message will appear.
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Map

TheMap tab allows the user to select the various options related to mapping process.Map Rendering
allows the user to choose between either a full Colormap, or a Luminancemap which varies from white
to dark blue. Users can also set whether or not to display invalid points, whether to use a linear
interpolation between points, and what size font the results display as on themap.

Stage Motion allows the user to enable high speed motion controls, for faster mapping when the
vacuum is in use. Reference Location allows the user to choose where on the sample to take the
referencemeasurement. The default setting is automatic, and will take the referencemeasurement at
(0,0) or a custom location can be defined. These options are not available for the StageBase-XY8-Auto-38
mm.

Focus Height Calibration can be used to manually re-home the z-motion of the system, and also to set
an offset for focus height.

Stage Center Calibration is used to ensure that the sample is fully centered on the stage, and is most
important when working with patterned samples. Instructions on how to use the function are included
in the software.

When Automatic Data Saving is enabled under the Edit Recipe > Wafer Map tab, the options here are
used to determine in what format the spectra are saved, and where on the computer they are saved.
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Uniformity Calculation allows the user to determine the equation used to calculate the uniformity result
in the wafer map.

The final three options allow the user to automatically clear the history whenever a newmap is started,
and if that option is enabled to automatically save the history file created with each map. The user may
also tell the system to automatically clear any spectra from theMeasure tab when maps are completed.

Data Recording

TheData Recording tab allows for automatic saving of all spectra and results to a central file. The user
can also select between having the software provide a prompt for which data to include in the history file
when using Acquire > Continuous Measure or to record all measurements to theHistory tab.
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Service/Maintenance

The Service/Maintenance dialog is used to enable and disable the vacuum, as well perform some basic
service functions. No adjustments should bemade to these settings without the supervision of a trained
Filmetrics engineer.

1.6.4 Acquire Menu

Acquire > Acquire One Spectrum
This function collects a single spectrum and displays it on the screen. No analysis is performed until the
recipe is changed or the Analyze button is clicked.

Acquire > Acquire Continuously
This feature collects real-time data from the spectrometer. It is useful when searching for a specific
location to measure (for example, locating a more uniform area of the sample, or one that exhibits
interference fringes). Stop continuous data acquisition by selecting Acquire Continously again.

Acquire > Measure Once
This feature collects a spectrum, analyzes it and displays it on the screen. This is the same as pressing the
Measure Button.
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Acquire > Measure Continuously
This feature collects real-time spectrum data and analyzes it – similar to repeatedly pressing theMeasure
button. Ameasurement interval time can be set in the recipe using the Advanced options underneath
the tab. Stop continuous data acquisition by selectingMeasure Continously again, or by pressing
Ctrl+M.

Batch Acquire
The Batch functions allow you to act on groups of spectra, rather than each individual spectrum

Acquire > Batch > Acquire
This option allows you to acquire a pre-selected number of spectra. You can also choose to save the
batched spectra as they are acquired.

Acquire > Batch > Measure
This option allows you to acquire and analyze a pre-selected number of spectra. You can also choose to
save the batched spectra as they are acquired.

Acquire > Batch > Analyze Spectra
This option allows the user to select multiple spectra for analysis by the current recipe. If there aremore
spectra to be analyzed than the software is set to Display, the analyzed spectra can easily be retrieved
from the tab.

Acquire > Batch > Analyze All Spectra in Folder
This option will analyze every spectrum in a folder with the currently selected recipe. If there aremore
spectra to be analyzed than the software is set to Display, the analyzed spectra can easily be retrieved
from the tab.
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1.6.5 Help Menu

Diagnostics
The diagnostics window gives information regarding the data taken during the baseline. Reference and
background counts are shown (this is useful to see howmuch signal the system is getting; good signals
typically are between 2500-3500 counts).

Help > Diagnostics shows the user information regarding the data taken during the baseline routine.

Help > About FILMapper
Information about the hardware and software versions and the system serial number can be found here.
Please have this information available when calling Filmetrics for technical assistance.
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Help>About FILMapper... window

1.7 Taking a Baseline

The baselinemeasurement allows the FILMapper software to take into account the response inherent to
the reflectancemeasurement hardware. It does this by first measuring a supplied sample, then a
reflectance standard, and finally taking a “dark” reading. The light source should be allowed to stabilize at
least ten minutes before the baseline is taken. When measuring films less than 1000 Å thick, the baseline
should be periodically re-taken every 20-30minutes. For thicker films, a new baseline can be taken less
often.

Baselinemeasurements may be started two ways:

1. Select the Baseline button in theWafer Map orMeasure Tab, which will guide the user through the
baseline procedure, or

2. Select Setup>Standard/Background... from themenu bar in theMeasure Tab for manual access to the
baseline functions.

The first step of the baselinemeasurement is to take a spectrum from your sample. This done by placing
the sample on the stage, and if necessary moving the stage over the sample using theGo To function.
With the sample in place under the light path, you can then press the Take Sample Reflectance button.
For systems with no z-motion, the software will automatically move to the next step of the baseline.
Systems with manual z-motion will instead prompt the user with theMeasurement Spot Focus dialog
pictured below. This dialog allows the user to move the stage and automatically adjust the gain to best
analyze the raw signal data.Once the system has been focused you can continue by pressing the OK
button. Systems with automated z-motion will focus automatically.
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The second step is to measure a reflectance standard. For systems with no z-motion, use a reflectance
standard that is closest in height to your sample. This is to account for the fixed focus point, which you
can read more about here. Click on Take Reflectance Standard to continue the baseline. For systems
with manual z-motion, the software will prompt you to refocus the system similar to the last step.
Replace your sample with the reflectance standard that most closely matches the overall reflectance of
your sample, and then refocus the system. Also as before, automated z-motion systems will
automatically refocus to the reflectance standard height. The reflectance standard that is used should be
selected from the Reference Material: list. For referencematerials not in the list, reflectance versus
wavelength values may be entered into a comma-delimited text file with the extension “.rrr” (stored in
theMaterial subfolder).

The background scan will be taken automatically. Most stages have a built-in tilted mirror or other
reflector that is used to re-direct the incident light away from the collection optics.

When thin films (< 2000 Å, approximately) or n and k are being measured, a full wafer referencemap will
be required, and automatically measured. To determine if full wafer reference data is required,
FILMapper checks the active Recipe settings. The pattern defined in that recipe will be used for the full
wafer reference. If themap pattern, edge exclusion, or wafer diameter is changed, a new full wafer
reference will be initiated. The full wafer referencemap can be enabled or disabled underneath the Edit
Recipe>Wafer Map tab.

After acquiring a baseline, the instrument is ready to begin making measurements. To verify that the
system is working properly, you may select Acquire>Single Acquire from theMeasure Tabmenu bar,
with the reflectance standard in place. You should see the reflectance spectrum of the reflectance
standard.
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2. Editing Film Recipes
The description of the nominal film structure, as well as themeasurement parameters, is specified in the
Edit Recipe dialog box. Hundreds of different film structures and their measurement specifications may
be saved.

The Edit Recipe dialog box is accessed with the Edit Recipe... button on theMeasure Tab, or the Edit…
button on theWafer Map Tab. The Edit Recipe dialog box lists an initial guess at the specifications of the
film structure to bemeasured. These specifications include the number of films in the structure, the layer
order of the films in the structure, the specifications of individual films (thickness and index), and the film
parameters to bemeasured.

2.1 Adding, Changing, or Deleting a Structure

When the Edit Recipe dialog box is opened, it shows the stored specifications of the structure selected
from the Recipe Name: list, along with any changes made since the recipe was loaded. Changes to the
structure selected can be permanently stored by making the desired changes and then clicking on Save.
Changes can also be stored as a new recipe by clicking on Save As. A structuremay be deleted (removed
from the Recipe Name: list) by clicking on theDelete button.

The Film Stack tab is used to define the film structure and desired measurement units, as well as the
starting guesses and constraints for thickness, n, and k. This is also where you determine any
Nonuniformity that may be present in the sample. The [+] and [-] above Composition, Thickness and
Nonuniformity can be used to expand or hide solving options.

2.1.1 Setting Up a Film Stack
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When measuring a layer, the parameters (thickness, n, and k) of the known films (including the incident
medium and substrate)must be entered into the proper fields in the Edit Recipe dialog box, as well as
initial guesses for the values to bemeasured. The refractive index (n) and extinction coefficient (k) values
for common materials can be selected from the drop-down menus on the right-hand side of the listed
materials, or by left-clicking on thematerial and using the Search function. Note that if a generic index is
selected, the software will instead prompt for a new index value.

If a material is being measured is not present in thematerial library there are three possible approaches
to complete the recipe:

a) Choose a material in the library that is similar.
b) If thematerial is transparent (an insulator), select “Enter Refractive Index Value” from the
material list and enter a value for the refractive index (n will automatically be varied by FILMapper to
account for dispersion effects, with the entered value being n at 632.8 nm).
c) Create a newmaterial file using the Edit > Material Library… dialog box. Enter the refractive index
values for n and k as a function of wavelength and save the files so that they may be selected as in
the recipe. See Creating and Editing n and k Files for more information.

2.1.2 Choosing the Films to be Measured
To measure a film's thickness, mark the check box on the right-hand side of the Thickness field under the
Film Stack tab in the Edit Recipe dialog box. When no boxes are checked, the theoretical spectrum for
the specified layer stack and thicknesses entered in the recipe will be displayed.

As with most measurements, the uncertainty of themeasured data increases as the number of
simultaneously measured values increases. Thus it is best to provide as much information about the film
structure as possible.

2.1.3 Constraints
By setting constraints, the user can limit the possible values of themeasured film properties. The
constraints are set in conjunction with the values entered in the Range dialog box for Thickness. For
example, if the initial guess of themeasured thickness of a film is 100 nm and the thickness constraint is
set at 50%, FILMapper will only consider possible thicknesses in the range 50 nm to 150 nm. The
constraints for n and k are set using the n and k dialog boxes under Composition. These boxes are only
visible when the Thickness or Composition options are expanded.

You can select between constraining by a percent of the thickness guess, or by absolute thickness units
by clicking on the % or measurement unit above the constraints dialog box. Constraining the
measurement range can speed up analysis and can also help exclude non-physical solutions.

2.1.4 Units
TheUnits drop down menu allows the user to easily switch between their desired measurement unit,
ranging from angstroms up to inches. The software will automatically convert between units when a
different unit is selected (e.g. 1micron will be converted to 1000 nm).

The Custom Unit function allows you to create your own custom unit for measurements if themetric
you'd like isn't already available in the drop-down list.
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The Edit Custom Units dialog box.

To determine the correct coefficient to use, you must first know the relationship between your unit and
nanometers. For example, if your units aremg/ft2 and it's been determined that 1mg/ft2works out to a
film thickness of 150 nm, then you would calculate your coefficient as follows, where X is the coefficient.

Custom units can be saved as part of the Recipe file, and only one custom unit can be saved per recipe.

2.1.5 Composition
When measuring the n and k of a film, the general dependence of these values upon wavelength must be
specified. This dependence is determined by the type ofmaterial to bemeasured. For example,
insulators, semiconductors, and metals all have a unique type of n and k wavelength dependence.

Dozens ofmodels for these different dependencies have been proposed and used over the years.
FILMapper uses a few of themost versatile and accepted models. For insulators the Cauchy model is
used, for semiconductors either the Amorphous or Bridge-Lorentzian model, and for metals the Drude
model.

There are also a number of special-purposemodels for specific applications. Thesemodels, and starting
coefficients values, are selected automatically when a material is chosen from theMaterial lists in the
Edit Recipe dialog box. Other models may also be specified by selecting them from the nk Model drop-
down menu under the Composition tab which is accessed by right clicking on theMeas checkbox when
solving for optical constants is enabled.

2.1.6 Grid Search for Thickness
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There are a number ofmethods that FILMapper can use to determine thickness. Each is a different trade-
off between speed, accuracy, and robustness (i.e., the ability to find the best solution among many that
are nearly as good). Because thickness can vary over many orders ofmagnitude and many near-
solutions may exist, it is often best to use a very robust method to get close to the best solution, and
then let a more accuratemethod take over.

One very robust method is theGridmethod, which can be activated by selecting theGrid option in the
Refine via drop-down menu. TheGridmethod searches the entire allowed thickness range (as defined
by the initial guess and the constraints) to find the best initial thickness. However, on some very complex
multilayer spectra, it is possible for the Grid method to give the wrong answer. In such cases it is best to
use the Fourier Transform(FFT)method to determine initial thicknesses, or to provide them manually.

2.1.7 Fourier Search for Thickness
The FFT option in the Refine via drop-down list is an alternative option to let FILMapper choose an initial
thickness for analysis. The Fourier Transform method analyzes the oscillations present in the spectrum
and determines the film thicknesses based on the periodicity of those oscillations. It is generally
somewhat less robust than theGridmethod, but is better at finding the correct thickness in cases where
the shape of the initial theoretical spectrum is different than themeasured data (i.e., the reflectance
spectrum is non-ideal in someway) or occasionally in cases where there is more than one film thickness is
being measured.
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2.1.8 Nonuniformity

The Edit Recipe > Film Stack tab with the Nonuniformity option expanded.

Selecting this option enables modeling of thickness nonuniformity within themeasurement spot. An
initial guess forNonuniformitymust first bemade, and then solving can be enabled or disabled by
toggling the Vary box. If solving is not enabled, the software will assume the value provided for
nonuniformity.

Note: Solving for nonuniformity can greatly increase solving time.
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2.1.9 Search

The Search Materials dialog box is accessible by left-clicking on a material name in the Edit Recipe > Film
Stack tab, or by selecting Search... from thematerial selection drop-down list.

Note: When clicking on a generic index file, the software will instead provide you with a dialog to enter a
new index value.

This feature allows the user to search for materials by using either thematerial name, or a keyword for a
certain class ofmaterials. The search function will also show a briefDescription of thematerial selected,
as well as any Synonyms or Keywords related to thematerial file. When files have a Synonym, that
means they are referencing the samematerial file under different names. For example, if Silicon is
selected the file that will be shown in the Film Stack is Si, not Silicon, as that is the file both names are
referencing. The Similar Materials box will list any materials that may have similar optical properties.
Correct setting of the following options will help ensure accuratemeasurements. Many of the options
are set automatically when film information is supplied in the Edit Recipe dialog box, and all of them can
be saved so that subsequent measurements can bemade as quickly and easily as possible. If Robust
(Adaptive; Thickness Only) or FFT (Thickness Only) is checked
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2.1.10 Data Selection

Wavelength Range
This sets the wavelength range that is to be analyzed. It may be set as either the entire range displayed
on the graph or a fixed range as defined by the user. Wavelength rangemay also be changed by clicking
and dragging the ends of the gray bar near the bottom of the graph area in themain FILMapper window.
Moving the bar will cause the software to reanalyze the data in the newly selected wavelength range.

Smoothing
This function performs wavelength-dependent boxcar averaging on themeasured spectra. This can
improve signal-to-noise levels and can filter out oscillations that correspond to optical thicknesses
(defined as thickness * refractive index) equal or greater than the specified value. This value should be
lowered to increase smoothing, and raised to decrease smoothing. To eliminate smoothing, enter a very
high value (1000 μm, for example).

Source Data
If more than one data set is present, this option tells the software whether to analyze the 0 degree
reflectance data, 0 degree transmittance data, 70 degree reflectance data, or some combination of the
three.

Note: While every Filmetrics system is capable of opening and analyzing spectra with 70 degree
reflectance data, only the F10-RTA is capable of collecting this data.

2.1.11 Enable FFT (Thickness Only)
The FFT (thickness only) solver is one of three analysis methods available in the FILMapper software.
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This solver is best suited for films greater than 250 nm thick, as well as multi-layered films. It is also an
effective option when the index of refraction of the film isn't well known. While this feature is selected
there will be fewer options under the Analysis Options tab. You cannot solve for index, roughness, or
nonuniformity with the FFT (thickness only) solver enabled. More information on the solver can be
found here.

2.1.12 Enable Robust (Adaptive; Thickness Only)
The Robust (adaptive; thickness only) solver is the second of three analysis methods available within
FILMapper. It is best suited for measuring the thickness of single-layer films greater than 150 nm thick.

This method can oftentimes successfully measure films when the data is affected by non-ideal properties,
such as thickness nonuniformity, grading, and birefringence. Much like the FFT (thickness only) solver,
enabling Robust (adaptive; thickness only) will limit the options available in the Analysis Options tab.
You also cannot solve for roughness, nonuniformity or index with the Robust (adaptive; thickness only)
solver enabled.

2.1.13 Exact Spectrum Matching
The Exact Spectrum Matching is the third of three analysis methods available in FILMapper. This solver
can be used to measure thickness, thickness nonuniformity, and roughness of single and multilayer
films, and can additionally solve for index.

Unmodeled Backside Reflections
When measuring films on transparent substrates, reflectance off of the backside of the substratemay
occur. Selecting Compensate for: Unmodeled backside reflections allows the software to shift the
intensity of the calculated reflectance curve to account for the additional light. This feature should not be
used when measuring very thin films (< 100 nm).

Tilted Sample/Lost Light
Samples with non-coplanar surfaces scatter some of the light away from the collection optics. This option
automatically compensates for the light lost due to nonplanarity.

Lock Identical Layers
Samples comprised of repeating layers can bemore accurately measured by activating this option. By
activating these options, all properties of any layers that initially have the samematerial or thickness are
locked together.

2.1.14 Analysis Options: Advanced
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Advanced Analysis Options for Spectrum Matching.

Convergence Criteria
This sets theminimum GOF between themeasured and calculated spectra that is attained before the
measurement routines consider the solution final. In most cases a value of 0.999 is sufficient. For cases
where the desired GOF is not attainable, the value in theMaximum Iterations field limits the number of
iterations performed by the analysis routine.

Solver Cycles
This option will enablemultiple solver cycles, with the number of cycles being defined by the number
entered in the text box. When using this option, the software will run through themodel for a solution
once, and then try again starting from the solution previously found. This can help find the best solution
amongst a number of near-best solutions, which can be the case when solving for a large number of
parameters (several thicknesses and/or refractive index). A greater number of cycles will lead to a longer
solving time.

Display Details
This feature controls the wavelength at which n and k are displayed in theMeasurement Details portion
of themain screen. These values are only displayed if solving for n or k is selected in the Film Stack tab.
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Advanced Analysis Options for FFT Analysis.

FFT Analysis Window
When the FFT solver is selected, the advanced options give you access to various settings to help
optimize analysis performance. When Optimize Position is selected, the solver will check for the best
possible GOF value in different areas across the spectrum in a wavelength range defined by the entered
window size. For example, if a window size of 200 nm is selected, the solver will look at six different 200
nm sections of the spectrum, and then select the range the provides the best GOF.

IfOptimize Size is selected, the solver will instead begin with a minimum window size as defined by the
user. It will then start at the center of the analysis range, and then extend equally in both directions six
times to find the best GOF. When Optimize Position and Size is selected, the software does both
functions, resulting in measuring thirty-one different combinations of location and analysis range.
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2.2 Map

This wafer map tab allows the user to specify various settings in relation to how themap is generated.
This includes the size and type of wafer to be analyzed, the configuration of themeasurement spots,
which parameters should bemapped, where AutoFocus functionality should be used if available, as well
as data saving protocols. It also allows the user to define settings for pattern avoidance and accounting
for invalid measurement spots. This is also where the preferences for the full wafer reference are set.

2.2.1 Measurement Configuration
Wafer Diameter: Diameter of wafer to bemeasured – choose from list. When using rectangular patterns,
this option will switch toWidth and Height, with text boxes to enter the appropriate values.

Coordinate System: Polar, Rectangular, Linear, or Custom.



48

Number of Points or Custom Name: Choose from the list the number of points to bemeasured or
select the name of the custom pattern file.

Edge Exclusion: Distance from outermost points to the edge of the wafer.

Wafer Details: Opens the Edit Wafer Details dialog box, which is used to determine the location of the
indexmark on the wafer.

Advanced Settings: When using a rectangular map, the advanced rectangular map settings option is
enabled for use. This menu allows the user to define the sample origin point in one of five locations; top-
left, top-right, center, bottom-left, or bottom-right. Automatic Alignment can be used to help find the
edges of the sample.

Edit Wafer Details
The Edit Wafer Details window is accessible underneath the Edit Recipe > Wafer Map tab. It allows the
user to configure the recipe for the type of substrate being measured, round or rectangular.
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For round wafers, the Indexing Mark (either notch or flat), wafer Diameter, and Index Mark Orientation
are specified. TheDiameter is selected from the pull-down menu, and the Indexing Mark is selected by
clicking on the Flat orNotch option. The system will limit the available indexing options based on the
wafer diameter selected. For wafer with minor flats (150mm and smaller), theMinor Flat Present check
box should only be selected if one is present.

The example shown above indicates a 200mm wafer (Diameter) with a notch (Indexing Mark) located in
the 6:00 o-clock position (Index Mark Orientation)

TheWafer has rough surface near edge check box is only for wafer with coatings or features that have
very low reflectivity at, or near, the edge of the wafer. This features calls a flat finding routine that is more
robust, but is much slower, than the standard flat finding routine and should only be used when
necessary.

The Prealigner option is only available if the option has been included with the system in question. When
theUse Prealigner box is selected in the recipeWafer Details window, the wafer will bemoved from the
cassette to the prealigner for centering and orienting the wafer so that its center is in a predefined
position and its mark (flat or notch) is at a predefined angle (direction), and then to the wafer chuck. The
system then skips the wafer chuck based centering and orienting and proceeds with themeasurement.
For patterned wafers, it should be confirmed that the system can reliably find the Deskewmarks and
subsequent measurement locations. If not, changes to the recipe, such as the Deskew and Registration
Mark search area box size, or robot station information, may need to bemade.

Note: The Use Prealigner option will only be available for wafer sizes that are compatible with the type
of prealigner that has been ordered. The option will be grayed out for incompatible wafer types.

2.2.2 Automatic Data Saving
If a filename is entered in the upper right corner of theWafer Map View>Map Information field, then a
new folder with that namewill appear in the FILMapper\MapResults folder. If no name is specified, all
saved data will appear in theMapResults folder.

Save Results to Disk: Automatically saves themap after completion ofmeasurement. This comma
delimited text file contains measurement coordinates and results.

Save Spectra: Saves the spectrum acquired at each point as a separate file. Each file is saved in
measurement order, "0" being the first measurement. File extension is .fmspe by default, but can be set
underneath the Setup>Options>Wafer Map tab. Each spectrum may be opened in theMeasure Tab.

2.2.3 Pattern Avoidance
The pattern avoidance feature enables the system to target areas on a patterned wafer that do not
scatter light (i.e. avoid trench areas). If a measurement shows low reflectance, the stage will move to a
nearby location where a pad is expected (as defined by the settings described below). This feature should
not be selected when measuring blanket wafers.

Spot Size: The size of themeasured spot.
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Pattern Size: The size of the features to be avoided.

Rectangular, Radial: The pattern layout geometry.

Spacing: The center-to-center separation of elements making up the pattern.

2.2.4 Invalid Measurement Retry
Activating this feature allows the software to try up to 4 additional measurement locations, within the
Spot Size specified from the designated location until a valid measurement is made. “Invalid”
measurements are defined in the Constraints tab. This function is especially helpful when measuring
non-uniform samples.

2.2.5 Additional Parameters To Be Mapped
Average Reflectance Ratio: This maps the average reflectance ratio, which is defined as the average
reflectance between the Starting Wavelength and the Ending Wavelength, divided by the reflectance at
the specified Reference Wavelength. TheGoodness Of Fit can also be included as a parameter to be
mapped. For systems with automated z-motion, the focus height can be tracked as well.

2.2.6 GOF (Solve for Goodness of Fit)
Enabling this feature saves GOF results with themap. To see the GOF map, use the drop down above the
Manual Color Range box under theWafer Map Tab.

2.2.7 Full Wafer Reference Mode
This option allows you to choose whether or not to enable Full Wafer ReferenceMode, or to let the
software decide based on the parameters set to be solved for. A full wafer reference is suggested when
mapping for optical constants, or very thin films (< 50nm).

2.3 Alarms
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Minimum Valid GOF
Constraining theMinimum Valid GOF will excludemeasurements where the calculated GOF does not
reach the specified limit. Awarning or “Invalid” result will appear if the GOF constraint is not met. Specify
0 to have all solutions reported.

Activate Alarms
When Activate Alarms is selected, an alarm will trigger if themeasured thickness of the sample is outside
the specified Thickness Limits. Measurements that fall within the thickness limits will be indicated by a
green box surrounding themeasurement result in theMeasurement Status window under the . A
measurement that falls outside of the selected limits will instead show a red box surrounding the
measurement result.

Thickness Limits
Setting theminimum and maximum allowable thickness limits will trigger an alarm if themeasured
thickness is outside the limits when Activate Alarms is selected.

This menu lets the user controlMeasurement Timing, Spectrometer Type (on EXR and UVX systems),
AutoFocus settings, and Advanced Acquisition Settings.

2.3.1 Measurement Timing
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Use Recommended Sampling Time
Selecting this option uses the sampling time that has been automatically calculated by the software
during the baseline procedure. The displayed value is the total sampling time and not necessarily the
integration time. To see the integration time and number of integration cycles go to theHelp >
Diagnosticsmenu.

Use Maximum Sampling Time
Users can set a maximum sampling time by selecting this option. By increasing sampling time the user
may see a decrease in signal noise, but at the trade-off of a longer acquisition time. Integration time and
cycles will still be determined by the FILMeasure software.

Use Manually Set Parameters
Users can set both the integration time per acquisition cycle and the number of integration cycles over
which to average. When using this option, the total sampling time is equal to the integration time
multiplied by the number of integration cycles.

To set the integration timemanually, set the sample on the stage and select Setup>Raw Signal… If the
proper integration time is unknown, an initial value of 40ms is a good starting guess. The vertical scale of
the spectrum extends from zero to 4000. Thus, a good working level is when the peak height of the
sample being measured, or the reflectance standard, whichever is greater, is 3000-3500 counts. If the
maximum signal is too low, increase the integration time. Too large an integration timewill result in
excessive dark current, so it is sometimes necessary to accept a smaller signal level to limit the dark
current.

Notes:
1. If the reference measurement saturates, the software will display a detector saturation error.
Analyzing a saturated spectrum will result in spurious final measurements. Take a new baseline
with a lowered integration time.
2. If the integration time is changed, it will be necessary to perform the baseline procedure, or re-
acquire the reflectance standard and background scans.

2.3.2 Spectrometer Type
EXR and UVX systems have two spectrometers(VIS-NIR and UV/VIS-NIR respectively). Here the user can
choose to use only one or both spectrometers.

2.3.3 AutoFocus
For systems with automated z-motion, FILMapper is capable of autofocusing on the sample and
reflectance standard when making measurements. There are three different options available to users:

GOF: This autofocus function is intended to optimize focus based on the best goodness of fit measured
off the sample. It is important to make sure that the recipe selected accurately matches the intended
application to minimizemeasurement time.



53

Max Signal: This autofocus technique works by maximizing the raw signal returned from the
spectrometer to determine best focus. It is the fastest of the three options.

Image Focus: Only for systems with the integrated camera, this technique focuses based on the image
from the SampleCam.

Regardless of technique used, it is suggested to first use themanual focus controls to bring the system to
a rough focus the first time you run a sample to minimize search time for the autofocus function.

Store Baseline settings in Recipe
This option allows the user to save the selected Optics Configuration, Baseline Name, and Reflectance
Standard used with each individual recipe.

Continuous Measure Settings
This option allows the user to set an interval, in seconds, between measurements when using the
Measure > Continuous Measure command from the Acquire Menu. By default this is set to 0.
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3. Making Measurements
Focusing on systems with the automated z-motion controller is very similar to that of the fiber with lens
assembly or microscope based systems, only with the controls for height adjustment included in the
software.

1. Turn on the light source for the system.

2. Start FILMapper.

3. Go to the Setup>Raw Signal… dialog box, set the integration time for 20milliseconds, and click
Apply.

4. Place a reflective sample, such as a silicon or BK7 reflectance standard on the sample stage. You
will now see the raw signal from the image sensor. If the signal exceeds 4000 counts, reduce the
integration time .

5. Adjust the focus to maximize themeasured signal using the focus controls in the software.

6. If micropositioners are present on the optical assembly, F3-XXT systems for example, they may
be adjusted at this time . Alternatemaking adjustments between the two knobs until signal is
maximized. As the system is very sensitive to the tip/tilt adjustments being madewith the
micropositioners, it is important that adjustments aremade slowly and in small increments.

7. Close the Setup>Raw Signal… dialog box. Focusing is now complete.

You will be prompted to focus the system during the Baseline during both the sample and reference
steps. For themost accurate results, it is important to refocus to your sample after the Baseline.

3.1 Using the Autofocus Feature (if present)

This section will cover the additional options made available to user for F60's with the optionalAutofocus
upgrade.

To use the autofocus feature, the user must first enable the function in the recipe underneath the
Acquisition Settings tab, and then pick between one of the three autofocus routines.
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GOF: This routine searches for optimal focus by measuring the sample against the current recipe, and
then selecting the focus height that provides the highest GOF value. When using this feature it is
important to make sure that the recipe selected matches the sample to bemeasured.

Max Signal: This routine searches for optimal focus by looking for the highest raw signal reflectance from
the sample. For transparent samples, it is suggested that the user enter a sample thickness or Z offset to
help insure the focus routine focuses to the top surface.

Image Focus: This routine is only available on systems that also have the integrated SampleCam. This
routine searches for optimal focus using the camera image provided from the sample cam.

Once an autofocus routine has been selected, you will also be able to add Focus Height as a variable that
can be displayed on your measurement maps by clicking on the box underneath the Additional
Parameters To Be Mapped section of theWafer Map tab in the recipe.
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3.2 Example A - Mapping Thickness Only

Measuring the Thickness of SiO2 on Silicon
For this example wewill demonstrate only themeasurement of SiO2 on silicon, but this type of
measurement has an extremely broad range of applications, including photoresists, hardcoats and
polysilicon, to name just a few.

Continue to Step 1...

Example A - Preparing the Film Stack

Step 1: Select the film stack
Select the film stack to bemeasured, in this case “SiO2 on Si”, from the Recipe: list box on themain
screen. If the film stack to bemeasured does not exist, continue on to step 2 to define a recipe (see
Editing Film Recipes). If the recipe does exist, continue to step 4.

Step 2: Edit the film stack
To edit the stack, click the Edit Recipe button to open the dialog box. Check to see that the film sequence
matches that of the actual sample. If not, different films can be selected. Also enter your best guess for
the thickness of the film to bemeasured, and check that only the SiO2 layer thickness is being measured.
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Example Edit Recipe>Film Stackwindow for measuring SiO2 on Si

Continue to Step 3

Example A - Preparing the Map and Baseline

Step 3: Edit the mapping routine
Edit the Edit Recipe>Wafer Map tab for the desired set ofmeasurement spots on the wafer. Use the
Wafer Details button to set the notch location on the wafer.

Example Edit Recipe>Wafer Map Tab for specifying mapping parameters.
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Step 4: Take a Baseline Measurement
Take a baselinemeasurement by first clicking on the Baseline button. A dialog box will appear to step
you through the process. In the Acquire Reference dialog box, make certain to select the reference
material that will be used (“Si” in this case). Then put the reference sample on themeasurement stage
and click OK. The dark measurement will automatically bemade after this referencemeasurement.

Continue to Step 5

Example A - Making the Measurements and Map

Step 5: Make the Measurement at a Single Spot ( only necessary on the first of a set of wafers )

Place your sample on the stage. After choosing an appropriate spot on the wafer using theGo To...
button, return to theMeasure Tab and make the thickness measurement by clicking on theMeasure
button. FILMapper will then acquire the reflectance spectrum and calculate the corresponding thickness.
If themeasurement was successful, theminima and themaxima of the calculated reflectance (the red line
on the graph) will coincide in wavelength with theminima and themaxima of themeasured reflectance
(the blue line on the graph.) In most cases they will not overlap, but will be separated in amplitude.

Measured and calculated reflectance spectra when measuring the thickness of SiO2 on silicon.
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If the calculated (red) and measured (blue)minima and maxima do not coincide, then themeasurement
was not successful. There are several possible causes of an unsuccessful measurement. Themost
common for this type ofmeasurement are described in the Troubleshootingsection.

Step 6: Map the Wafer
Having received an encouraging answer for the thickness at the specified spot, run the wafer mapping
routine by clicking on theMap button. The program will revert to theWafer Map Tab and will begin to
display the thicknesses on the wafer as themeasurements are being made. After themapping is
complete, a thickness color map will be generated and statistical analysis for the current set of
measurements will be presented.

Color wafer map of SiO2 on silicon.

To switch the color map display between multicolor and a single-color shading, go to the Setup>Wafer
Map Coloring…menu item.

3.3 Example B - Mapping Thickness and Optical Constants

Measuring the Thickness of Si3N4 on Silicon

For this example wewill demonstratemapping thickness and optical constants (n and k) of Si3N4 on
silicon.

Continue to Step 1...
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Example B - Preparing the Film Stack

Step 1: Select the film structure
Select the film stack to bemeasured, in this case “Si3N4 on Si”, from the Recipe: list box on themain
screen. If the film stack to bemeasured does not exist, continue on to step 2 to define a recipe (see
Editing Film Recipes). If the recipe does exist, continue to step 4.

Step 2: Edit the film structure
To edit the stack, click the Edit Recipe button to open the dialog box. Check to see that the film sequence
matches that of the actual sample. If not, different films can be selected. Also enter your best guess for
the thickness of the film to bemeasured, and check that the Si3N4 layer thickness (d), n, and k are being
measured.

Example Edit Recipe>Film Stackwindow for measuring thickness, n, and k of Si3N4 on Si.

Continue to Step 3...

Example B - Preparing the Map and Baseline

Step 3: Edit the mapping routine
Edit the Edit Recipe>Wafer Map tab for the desired set ofmeasurement spots on the wafer. Use the
Wafer Details button to set the notch location on the wafer.
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Example Edit Recipe>Wafer Map Tab for specifying mapping parameters.

Step 4: Take a Baseline Measurement
Take a baselinemeasurement by first clicking on the Baseline button. A dialog box will appear to step
you through the process. In the Acquire Reference dialog box, make certain to select the reference
material that will be used (“Si” in this case). Then put the reflectance standard on themeasurement stage
and click OK. The dark measurement will automatically bemade after this referencemeasurement. A full
wafer referencemeasurement will bemade (i.e. each point of the pattern specified in the active recipe will
bemeasured).

Continue to Step 5...

Example B - Making the Measurement and Map

Step 5: Make the Measurement at a Single Spot ( only necessary on the first of a set of wafers )
Place your sample on the stage. After choosing an appropriate spot on the wafer using theGo To…
button, return to theMeasure Tab and make the thickness measurement by clicking on theMeasure
button. FILMapper will then acquire the reflectance spectrum and calculate the corresponding thickness
and optical constants. If themeasurement was successful, theminima and themaxima of the calculated
reflectance (the red line on the graph) will coincide in wavelength with theminima and themaxima of the
measured reflectance (the blue line on the graph.)
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Measured and calculated reflectance spectra when measuring the thickness, n, and k of Si3N4 on silicon.

If the calculated (red) and measured (blue) spectra do not fall on top of each other, the resulting
thickness, n, and k values are incorrect. If themismatch between measured data and calculation is only
slight, the results reported will only be off by a small amount. If themeasured and calculated spectra
match, but the results are implausible, theremay be a problem with the sample positioning and light
collection. Causes and corrective actions to improve themeasurement are listed in Case #5 and Case #6
in the Troubleshooting section.

Step 6: Map the Wafer
Having received an encouraging answer at the specified spot, run the wafer mapping routine by clicking
on theMap button. The program will revert to theWafer Map Tab and will begin to display the
thicknesses on the wafer as themeasurements are being made. After themapping is complete, a
thickness color map will be generated and statistical analysis for the current set ofmeasurements will be
presented. To view other parameters on the color map, select the parameters (i.e. refractive index) from
theDisplay: drop-down box.
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Map of the refractive index of Si3N4 on silicon.

3.4 Measurement Assumptions

The following assumptions must be valid if accuratemeasurements are to bemade.

1. Every film present in the structure is specified in the Edit Recipe dialog box. This includes every film
present in the sample including so-called adhesion films, oxide films (unless they are less than 20 Å thick),
and films on the bottom surface of the substrate if the substrate is transparent.

2. If the film is , it has been accounted for in the recipe.

3. The light source has been allowed to warm up for at least 5minutes if measuring thickness of films
greater than 250nm, or 15minutes if measuring thickness of films less than 250nm, refractive index, or
reflectance.

In addition, the following assumptions aremade if optical constants and/or very thin films (<500 Å) are to
bemeasured:

4. If any grading is present (i.e. the refractive index and extinction coefficient are constant as a function of
depth and constant over the entire spot being measured), it has been accounted for in the recipe.

5. The sample is flat. (The vacuum chuck may help in this case when samples are warped.)
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6. No changes to themeasurement system (such as fibers being moved) or light source have occurred
since the acquisition of themost recent baseline.

7. No significant changes in room temperature (> 5 degrees F) have occurred since acquisition of themost
recent baseline.

If any of the above assumptions are not true, it may still be possible to make a measurement, but
accuracy may be degraded.

3.5 Hints for Improved Accuracy

This section contains various tips to help improve accuracy in your measurements.

Roughness.

Restricting the wavelength range of the analyzed reflection spectra.

Measuring thickness when the approximate thickness is not well known.

3.5.1 Roughness
Slight amounts of surface or interface roughness that may be present can decrease theGOF value of a
measurement. Entering a value or solving for roughness can partially account for this roughness so that
a better GOFmay be achieved. Generally, roughness is only present when the sample surface looks hazy
at themeasurement spot. The fact that haze can be seen means that there is scattered light. (A perfectly
smooth surface will scatter no light, and thus themeasured spot will not be visible.) Usually roughness
less than 2.5 nm will not be visible, while roughness greater than about 25 nm will be extremely hazy.

FILMapper assumes a Gaussian distribution of the surface height irregularities about themean and it
assumes that the roughness is small compared to the wavelength. FILMapper reports the rms roughness
value.

3.5.2 Restricting the wavelength range of the analyzed reflectance spectrum
Occasionally spectra from measured films are adversely affected by factors such as absorbing dyes,
birefringence, or nonuniformity – all of which are difficult to model properly. It is often still possible to
make accurate thickness measurements of these films by analyzing only unaffected portions of the
spectra. The portion of the spectrum that is used to calculate film properties is determined in the recipe
underneath the Analysis Options tab.

You can also adjust the wavelength analysis range in themain FILMapper window using the gray bar at
the bottom of the graph. Click and drag either end of the bar to a new position on the x-axis to adjust the
analysis range.
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Example of a non-ideal film (spectrum with no oscillations at lower wavelengths) that requires reduced wavelength
range for accurate measurement.
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Example of a reduced wavelength range for measuring thickness of non-ideal films.

3.5.3 Measuring thickness when the approximate thickness is not well known
Unless otherwise specified, FILMapper will determine a film’s thickness by finding the best answer within
about 1000 Å of the initial (user supplied) value. If the approximate thickness of the film is not known to
better than about 1000 Å, then theGridmethod or the Fourier Transformmethod of determining
approximate thickness may be applied. See Editing Film Structures for more details.

3.6 Troubleshooting

For error messages or hardware problems encountered with your Filmetrics instrument, please use the
chart below to best diagnose your problem. For help with modeling, see Troubleshooting - Thickness
Modeling.

Question 1: Are you able to start FILMapper without an error message?
No: Continue to Question 2.
Yes: Continue to Question 1-1.

Question 1-1: What sort of problem are you seeing?
1: The lamp doesn't turn on or the fan isn't working properly. See theNon-Operating Box, Lamp, or Fan
Troubleshooting Guide.
2: I get an error message when I click on something. Continue to Question 1-1-2.
3: Measurement results are wrong or unstable, after they had been good. See theMeasurement Results
are Incorrect or Unstable Troubleshooting Guide.
4: Measurement and/or baseline takes longer than it used to. See the Slow Operation Troubleshooting
Guide.

Question 1-1-2: If you're still seeing an error after you've power cycled and installed new software,
then select the description which most closely describes your error.
1: The error occurs during the baseline. See the Error Message During Baseline Troubleshooting Guide.
2: Some other error. See the Error Messages -Miscellaneous Troubleshooting Guide.

Question 2: Are you able to launch FILMapper but it shows an error?
Yes: Continue to Question 2-1.
No: Then you need to install the software that comewith your new system, or you can request new
software. See the Software Reinstallation Guide.

Question 2-1: Does the error message start with "No Filmetrics instruments detected...."?
Yes: See theNon-Operating Box, Lamp, or Fan Guide.

3.6.1 Power Cycling
Over the years we've found that about a third of support issues can be resolved by simply power cycling
the Filmetrics system and computer. Follow the simple steps below to power cycle your instrument.
Further assistancemay be received by contacting us using themethods described in the Contact
Information section.
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Step 1: Shut down FILMapper (it's OK in the rare case that you can't).

Step 2: Unplug all electrical connectors from the back of your Filmetrics box.

Step 3: Restart your computer, giving it time to load all drivers.

Step 4: Reconnect the electrical connections to your Filmetrics box. (Make sure that the power cord is
getting power, and that any switch near the power connector is turned on.)

Step 5: Restart FILMapper

3.6.2 Software Reinstallation Guide
Follow the steps below to reinstall FILMapper. Further assistancemay be received by contacting us using
themethods described in the Contact Information section.Warning: Upgrading software versions may
result in slightly different (<1%)measurement results due to continual improvement of our solving
algorithms and material files.

Step 1: Shut down FILMapper (it's OK in the rare case that you can't).

Step 2: Unplug all electrical connectors from the back of your Filmetrics system.

Step 3: Are you installing this software on a computer which already has FILMapper installed?
Yes: Go to Step 4.
Yes: Jump to Step 6.

Step 4:Make a backup copy of your recipe and material files:
FILMapper versions 5 and up:
On Windows XP: Backup the directory C:\Documents and Settings\All
Users\Application Data\Filmetrics
Note: The application Data folder may be hidden by default.
On Windows 7/8/Vista: Backup the directory C:\Program Data\Filmetrics\
Note: The Program Data folder may be hidden by default.

Step 5: Uninstall the current version of software:
On windows XP: Click Start > Control Panel > Add or Remove Programs > FILMapper > Uninstall
On Windows 7/Vista: Click the Start orb > Control Panel > Programs and Features > FILMapper >
Uninstall
On Windows 8: Control Panel >More settings > Programs and Features > FILMapper > Uninstall

Step 6: Run the software installer and follow installer instructions.
Note: you will need administrative privileges to install the software.

Step 7: Reconnect your Filmetrics system.
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Note for Windows XP: The "NewHardware Found" wizard may appear if your instrument has a
USB connection. Youmust click "Next and complete the driver installation process. This dialog box
may appear multiple times depending on the system configuration.
Note for Windows 7/8/Vista: An Information balloon may appear over the taskbar while drivers
are being installed. Please wait until the balloon indicates the drivers have been installed before
starting FILMapper.

Step 8: Run the software to verify the installation was successful.

3.6.3 Non-Operating Box, Lamp, Or Fan
Follow the steps below to troubleshoot symptoms of a non-operating spectrometer, light source, or fan.
These are usually caused by having too much or not enough light. Further assistancemay be received by
contacting us using themethods described in the Contact Information section.

Step 1: Does the green LED on the right side of the front panel illuminate?
Yes: Jump to Step 3.
No: Go to Step 2.

Step 2: Is the power cord fully inserted into the back of the unit and a powered wall outlet? If your unit
has a rear power switch, is it on?

Yes: Go to Step 3
No: Plug into a powered outlet or switch on the unit

Step 3: Does the LED light on the light source switch illuminate when switched on?
Yes: go to Step 4
No: Possible faulty switch or faulty indicator lamp, contact Filmetrics.

Step 4: Is the cooling fan spinning? Determine this by listening to the cooling fan which is located
directly below the light source. (You'll need to get close to hear the fans on systems built after 2010.) For
F50 systems the chassis cooling fan is louder than the light source cooling fan. You'll need to get close to
the light source to hear the light source cooling fan.

Yes: Go to Step 5.
No: The cooling fan needs replacement, contact Filmetrics. Note: a bad cooling fan can draw
enough power to prevent the light source and box from operating properly.

Step 5: Does the light source illuminate?
Yes: Go to Step 6

Step 6: The following steps are to troubleshoot a box that is not being detected by the FILMetrics
software. This could be a software driver or (rarely) a hardware problem. To see what hardware your
computer is detecting, look in the windows devicemanager. (instructions on how to access the Device
Manager are included at the end of this document.)

In the DeviceManager, which device do you see?
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"Filmetrics Measurement Instrument" or similar: In this case the system should be operation
correctly. If not, please contact Filmetrics.
"Unknown Device" or similar: The hardware appears to be operating properly, but the drivers for
the hardware are not installed. If you have already power cycled and installed themost current
Filmetrics software, please contact Filmetrics for further assistance.
Neither of the above: The hardware is not working properly. Go to Step 7

Step 7: Try a newUSB cable and plug it into a different USB port. Does this fix the problem?
Yes: Either the USB cable or port was bad.
No: The USB controller inside the FILMetrics boxmay be bad. Please contact Filmetrics.

Accessing Device Manager in Windows 7:
1. Click on the Start Orb.
2. In the Star Search box type: devicemanager. Press enter.
3. Select Devicemanager from the list.
4. You should see a Filmetrics Measurement Instrument tab. Expand the tab and the appropriate
driver should be listed for the Filmetrics instrument.

Accessing Device Manager in Windows XP:
1. Click Start.
2. Click on Control Panel
3. In the Control Panel double-click the Systems icon.
4. In the Systems Properties window click on the Hardware tab.
5. In the Hardware tab click the DeviceManager button.
6. You should see a Filmetrics Measurement Instrument tab. Expand the tab and the appropriate
driver should be listed for the Filmetrics instrument.

3.6.4 Error Message during Baseline
Follow the steps below to troubleshoot error messages encountered while taking a baseline. These are
usually caused by having too much or not enough light. Further assistancemay be received by
contacting us using themethods described in the Contact Information section.

Step 1:Which error message are you seeing while taking a baseline?
Received light signal is too bright: If you aremanually setting the integration time (see ) then you
need to reduce the integration time. Otherwise you can reduce the light source intensity by using a
flattening or neutral density filter. Optical filters can be purchased on our website,
www.filmetrics.com.
Baseline Failure. Reference and background spectra are almost the same: This error is often
caused by using the reference sample during the background step or vice versa, and is easily
corrected by taking retaking the baseline while providing the proper material for the proper step. If
this is not the case, go to Step 2.
Spectrometer peak intensity is x% of previous reference intensity: This error is often caused by
using the incorrect reference sample and is easily corrected. Jump to Step 5.

Step 2: Does the light source illuminate?
Yes: Go to Step 3.
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No: Check theNon-Operating Box, Lamp, Or Fan Troubleshooting Guide.

Step 3: Check to see if there is a broken or misconnected fiber. With the light source on, confirm that
the illumination fiber is screwed into the light source securely, and that plenty of light is exiting the fiber
at the far end near where the sample is placed. The light can be seen by placing paper (e.g., business
card) near the sample location (do not look directly into the fiber if you are using a UV source). If plenty of
light is seen, next check the return fiber by removing it from the spectrometer input and connecting it to
the light source (removing the other fiber first). You should see light at the far end as before, but it may
be 3-4 times smaller and dimmer. Did you see light at the sample end using both fibers in the light
source?

Yes: The fiber appears to be good. Replace the fibers securely in their original positions (there will be
a white band on the light source fiber if the two ends are different) and go to Step 4.
No: The fiber optic may be broken. Replacements can be purchased on our website,
www.filmetrics.com

Step 4: Does your system havemultiple spectrometers (i.e. EXR or UVX)
Yes: Check the Acquisition Settings tab under Edit Recipe to make sure that your fiber optic
configuration matches the enabled spectrometers. Do this by making sure that each enabled
spectrometer has a fiber attached to it (or disable a spectrometer that is not being used).
No: If you are still experience problems, please contact us using the Contact Information section.

Step 5:Was the correct reference selected from the drop-down list?
Yes: Go to Step 6.
No: Re-baseline using the correct reference.

Step 6: Has the light source lamp recently been changed?
Yes: This error is an expected response, no further action required
No: Go to Step 7.

Step 7: Has the optical configuration been altered (i.e. switching from standard spot size to small spot
optics or a contact probe)?

Yes: This error is an expected response, no further action required
No: If you are still experiencing problems, please contact us using the Contact Information section.

3.6.5 Measurement Results are Incorrect or Unstable.
Follow the steps below to troubleshoot when measurement results are incorrect or unstable after the
results had been good for some time. Additional help troubleshooting general measurement issues may
be found in the Troubleshooting: Thickness Modeling section. Further assistancemay be received by
contacting us using themethods described in the Contact Information section.

Step 1: First confirm that you have selected the correct recipe for the sample that you aremeasuring
(i.e., the same recipe that previously was giving good measurements). Note that this troubleshooting
guide does not cover instances where recipe parameters have been changed.
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Step 2: Confirm that the light source is turned on Place a piece of paper at the samplemeasurement
location and confirm that you can see a light beam. Can the light beam be seen?

Yes: Jump to Step 4
No: Go to Step 3

Step 3: Is there light coming out of the light source? (If you are checking a UV light source, put on the
goggles that were supplied with the light source before checking.)

Yes: It appears the fiber may be broken. Replacements can be purchased on our website
www.filmetrics.com

Step 4: Perform a new baseline, paying particular attention to make sure that you are using the proper
reference and that it is clean with the correct side up.

Step 5: Put a sample that is known to be good on the stage and perform a measurement. If the
measurement is still not correct, go to Step 6.

Step 6: Your lamp may be weak and needs to be replaced. .

If you are still experiencing problems with an unstable or incorrect measurment after the preceding
steps, please contact us using themethods described in the Contact Information section.

3.6.6 Slow Operation Troubleshooting Guide
Follow the simple steps below to troubleshoot slow system operation. Further assistancemay be
received by contacting us using themethods described in the Contact Information section.

Step 1:When did you experience the slow operation?
During a baseline: Go to Step 2.
When I click Measure: Jump to Step 7.

Step 2: Slow baselines are generally caused by a low light level, which can have several causes. Does the
light source illuminate (be sure it is switched on, and that the shutter is open on UV systems)

Yes: Go to Step 3.
No: Check theNon-Operating Box, Light, or Fan Troubleshooting Guide.

Step 3: Check to see if there is a broken or misconnected fiber. With the light source on, confirm that
the illumination fiber is screwed into the light source securely, and that plenty of light is exiting the fiber
at the far end near where the sample is placed. The light can be seen by placing paper (e.g., business
card) near the sample location (do not look directly into the fiber if you are using a UV source). If plenty of
light is seen, next check the return fiber by removing it from the spectrometer input and connecting it to
the light source (removing the other fiber first). You should see light at the far end as before, but it may
be 3-4 times smaller and dimmer. Did you see light at the sample end using both fibers in the light
source?
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Yes: The fiber appears to be good. Replace the fibers securely into their original positions on the
spectrometer box and light source (there will be a white band on the light source fiber if the two
ends are different) and go to Step 4.
No: The fiber optic may be broken. Replacements can be purchased on our website,
www.filmetrics.com

Step 4: Does your system havemultiple spectrometers (i.e. EXR or UVX)
Yes: Check the Acquisition Settings tab under Edit Recipe to make sure that your fiber optic
configuration matches the enabled spectrometers. Do this by making sure that each enabled
spectrometer has a fiber attached to it (or disable a spectrometer that is not being used).
No: Go to Step 5.

Step 5: It may be that your lamp is old and needs to be replaced. .

Step 7: Unless the slow operation during measurement is a new problem, please confirm that your
computer meets theminimum system requirements as listed in the system specifications. If it doesn't,
please upgrade your computer. Otherwise, go to Step 8.

Step 8: Ameasurement that takes a long time generally means that there is a large amount of
processing required to find a solution, which is usually caused by a non-optimal recipe setting. Please
first confirm that you have selected the correct recipe for the film stack you aremeasuring. Otherwise, go
to Step 9.

Step 9:Open the recipe and make sure that you are not solving for too many parameters. Solving for
one or two thicknesses or a thickness and index should only take a second or two, but in some
circumstances the solving time can be increased 5-10x for each additional parameter. Solving for
nonuniformity (or adding it to increase accuracy of other parameters) can be especially time consuming.

Step 10: If you are solving for more than one thick layer (i.e., >10 um), you can speed up the solving
process by reducing the thickness constraint range (which can be safely reduced even more by using an
accurate nominal thickness guess)

If you are still experiencing problems with a slowmeasurement after the preceding steps, please contact
us using themethods described in the Contact Information section.

3.6.7 Error Messages - Miscellaneous Troubleshooting Guide
This guide provides extended information on error messages a user may encounter on rare occasion
while using our software. Further assistancemay be received by contacting us using themethods
described in the Contact Information section.

Error during spectrum analysis/ unable to analyze spectrum.
This error is generally caused by a problem with the recipe constraints. Try adjusting the solver
wavelength range, thickness constraint range, or starting thickness value. Also make certain that the
starting thickness values have been entered using the correct units ofmeasure specified for the recipe.



73

Spectrum saturated.
This error indicates that the samplemeasured is more reflective than the spectrometer was expecting.
Reflectance data may not be accurate as a result. Take a new baseline to fix this problem.
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3.6.8 Troubleshooting: Measurement Results
In all cases it has been assumed that the user has read theMeasurement Assumptions section, and that
each criterion has been met.

Case #1: No oscillations, or portions of oscillations, are present in the measured reflectance
spectrum.

Case #2: The measured reflectance spectrum has periodic oscillations across the entire screen, but its
minima and maxima do not match up with the calculated reflectance.

Case #3: Two or more different, but nearly the same, thickness readings are obtainable from the
same measurement location.

Case #4: Poor matches between the measured and calculated reflectance spectra when measuring
thickness and optical constants.

Case #5: Several different answers, or one unreasonable answer, are found when measuring
thickness and optical constants, even though a good match is found between the measured and
calculated reflectance spectra.

Case 1: No oscillations, or portions of oscillations, are present in the measured
reflectance spectrum.
There can be several possible causes in this case;

1. The film may just be very thin (<200 Å), thus presenting no discernible oscillations or only one
identifiable minima or maxima. The solver will not be able to accurately analyze films without at least one
discernible full oscillation, in general meaning a film less than 0.2microns thick.

2. If the film is very rough, non-uniform in thickness over themeasurement area, or has a graded
interface it may not support coherent optical interference and thus it may not be able to bemeasured.
Try moving to a different measurement spot for a better signal.

Case 2: The measured reflectance spectrum has periodic oscillations across the
entire screen, but its minima and maxima do not match up with the calculated
reflectance.
Themost common cause is that the initial thickness guess was considerably different than the actual film
thickness, and due to the constraints on possible thicknesses, FILMapper was unable to find the correct
answer.
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To better understand this, it helps to know that the number of oscillations on the screen is proportional
to the film thickness. For example, if themeasured spectrum has roughly twice the number of the
oscillations that the calculated spectrum has, then themeasured film is roughly twice the thickness of
the calculated thickness. Using this information, the initial thickness guess and the thickness constraints
can be set more appropriately in the Edit Recipe dialog box.

Case 3: Two or more different, but nearly the same, thickness readings are
obtainable from the same measurement location.
When this occurs usually themeasured and calculated spectra match somewhat, but not very well
across the entire spectra (i.e., themeasured and calculated spectra match exactly only over a small
wavelength range and then gradually walk off one another outside this wavelength range). When
thickness is the only value being measured, this is normally caused by the refractive index of the
measured layer not matching that used by FILMapper, especially when the film is greater than one
micron thick. Unless more accurate index values can be obtained, the best way to solve this problem is to
restrict the wavelength range used in the analysis.

Case 4: Poor matches between the measured and calculated reflectance spectra
when measuring thickness and optical constants.
There can bemany causes of this problem, including those listed in Case #1 and Case #2 above. Most
commonly when a poor fit between the spectra occurs, it is because:

1) The components of the film structure are not all included in the Edit Recipe > Film Stack dialog
box. Adjust the recipe accordingly and reanalyze the spectrum.

2) Very inaccurate initial guesses for the film thickness(es) have been listed. Try a new nominal
starting guess, or expand the thickness constraint range.

3) The optical constants listed in the Edit Recipe > Film Stack dialog box are far from the actual
optical constants in thematerial. Try selecting a different but similar material file if one is present,
for example switching from Acrylic to Acrylic - 2.

4) The film being measured has properties that are not taken into account by FILMapper. Examples
of these properties are graded interfaces and non-uniform films. You can enable solving for these
conditions in the recipe.
Note: Enabling Nonuniformity solving will increase solving time.
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Case 5: Several different answers, or one unreasonable answer, are found when
measuring thickness and optical constants, even though a good match is found
between the measured and calculated reflectance spectra.
This normally occurs when a large number of properties are being measured on a very thin film. In
general, the thinner a film is the less unique information that can be obtained from it. To understand
this, see Theory of Operation. To solve the problem, you can either:

A. Decrease the number of variables solved for.
B. Increase the amount of data provided to the solver (analyzing reflectance and transmittance at the
same time, or using themulti-spectral solver).
C. Enablemultiple Solver Cycles under the Edit Recipe > Analysis Options > Advanced dialog.
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4. Understanding and Evaluating
Measurement Results
This section covers information on theDisplay of Measured Spectra and a more in depth look at the
Goodness Of Fit value.

4.1 Display of Measured Data

Once film stack and measurement information have been entered and a baseline has been taken,
measurements may bemade by clicking on theMeasure button. After measurement, themeasured and
calculated reflectance spectra are displayed on the graph, and the thicknesses of the films are listed in
the results box. If any of the thickness values weremeasured, they are displayed in bold numbers.

The quality and accuracy of the result is determined by howwell themeasured spectrum matches with
the calculated spectrum. In general, thickness information is determined by the number of oscillations,
and index information is determined by the amplitude of the oscillations. In the case of the Robust
(adaptive; thickness only) solver and Exact Spectrum Matching solver, a good result is one where the
minima and maxima of themeasured and calculated spectrum align. For the solver, this is when the
measured intensity peaks overlap. See theGoodness of Fit and Troubleshooting - Thickness Modeling
sections for more information.

4.2 Goodness of Fit

The accuracy of a calculation fit, and thus the reliability of themeasurement, can be judged by thematch
between themeasured and calculated spectra, which is quantified by the GOF value. GOF is a number
between 0 and 1.

A perfect match between measured and theoretical spectra will result in a GOF of 1. To ensure accurate
results the user may set a minimum acceptable GOF value by entering a number between 0 and 1 into
GOF Error on the Alarms Tab in the Edit Recipe dialog box. Awarning message will be displayed after
each measurement where the GOF falls below the user-specified GOF Error. If the GOF is less than 1 there
are several possible causes:

b) Incorrect Structure Definition – If the refractive index of one or more layers in the structure is
different from what is described in the recipe, then there will be somemismatch between the blue
curve and the red curve.

c) Graded Interfaces – The amplitude of the peaks in the spectrum depends on both the size of the
change in refractive index at each interface in the layer structure and the sharpness of the interface.
For example, in many hardcoat samples there is some degree of layer intermixing at the interface,
leading to a weaker than expected reflectance at that interface. In severe cases the peaks may
disappear entirely.



78

5. Advanced Features
This section describes several advanced features available within FILMapper. This includes the creation of
newmap files, editing those files within Windows Excel, and how to create and edit n and k files.

Editing Map Files Using Excel

Creating and Editing n and k Files

5.1 Creating New Map Patterns

The Edit Map Pattern tool is best used for simpler maps on blanket wafers. For more complexmaps, see
the Recipe Tab.To create a newwafer map pattern, go to the and select Edit > Map Pattern…Once
selected, a newwindow appears which allows parameters to be adjusted to create a custom wafer map.
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1. Select the shape of the wafer to be either Round or Square.

2. Select how themeasurement points are distributed on the sample. The alignment can be Radial
(Polar), Rectangular, or Linear.

3. Control themeasurement point density. The # of Spots from Center to Outer Edge specifies how
many points are placed in a line between center and edge. The Central Exclusion specifies howmuch of
the center (if any) should be excluded from measurement.

4. Select howmany spots are in each quarter section of the ring (when the Radial pattern type is
selected). WhenManual Spots per Quadrant is not selected, Ring 1 is automatically set to 1, and Each
additional ring is automatically set to 2.

5. Select whether themeasurement points should span the Center to Edge, or the Edge to Edge (only
available when the Linear pattern type is selected).
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6.Use Redraw to refresh the wafer map based on the current settings to make sure themap is correct.

7. Save the wafer map to a file, for subsequent use in a Recipe.

The user can also open an Existing Pattern for editing, or Import one that has been created using Excel.

5.2 Editing Map Files Using Excel

Map files can be edited further using Microsoft Excel in order to createmore complex patterns. The *.pat
file created by FILMapper can be imported into Excel for editing and saved as a comma-delimited file. The
newly edited file can then be opened using FILMapper to createmore intricatemap patterns. The
example below shows how to create an “X” pattern starting with the default pattern.

Example: Creating an “X” map pattern starting with the default map pattern

Step 1: Create a new map file
In themap window, go to Edit > Map Pattern…Using a Roundwafer type and a Radial pattern
type, select 3 for # Spots from center to Outer Edge. SelectManual Spots per Quadrant and use 2
for Ring 1 and Each additional ring.

Save this default map pattern as Custom.

Step 2: Import the map pattern into Excel
Using Excel, open the file Custom.pat. This file can be found in C:\Program
Files\FILMapper\Patterns\Custom\. (Note: If the file does not appear, in theOpen dialog box,
choose All Files (*.*) under File Type.)

You will be prompted to import this file; when prompted select Delimited and click Next. When
prompted, only select Comma for theDelimiters.

Step 3: Edit map pattern in Excel
Starting in the fourth row, the values are stored as x-y coordinate values, as a fraction of the radius
of the wafer. When generating newmaps, values can be entered as either a fraction of the radius of
the wafer or a discrete number as long as all values are to the same scale. To create the “X” pattern,
delete the highlighted rows shown in Figure 4.1, so that there are no empty rows between values.
Also delete the first two rows by selecting rows 1 and 2 and selecting Delete from the Editmenu.
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Delete the highlighted cells to leave the desired coordinates.

Step 4: Save map pattern
After themodifications have been made, select File>Save. Check to make sure that the File Name
box is “CustomEdit.pat” (note that quotation marks must be used to enclose the filename in Excel
to force the extension to .pat) and that the File Type is CSV (Comma delimited) (*.csv). Then click
Save.

Step 5: Import the Map Pattern
In FILMapper, click on the Editmenu and selectMap Pattern.... Enable the radio button for File-
Imported Pattern, and then switch to the Imported Pattern tab and click Open.... The following
dialog will open.
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Increase theOptions > Line to skip value until the first value visible in the list is the first coordinate
in the series. TheWafer Diameter/Width and Heightmust also be set here according to the values
you used for the coordinate scale you used. If you used fractional values, set theWafer
Diameter/Width, and Height for rectangular samples, to 2 (-1 to 1). If you used whole values, simply
enter the dimensions of your sample. Click OKwhen finished.

Step 6: Save the Pattern File
The new pattern file should now be displayed in the Edit Map PatternWindow. Confirm it matches
the expected pattern, and then save the new pattern using the Save As button.

Note: If the wafer map does not show up as described, open the file C:\Program
Files\FILMapper\Patterns\custom\Custom.pat using a text editor, such as Microsoft Notepad.
Check to see that the first row does not contain a comma. If it does, delete the comma and save the
file.
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Figure: “X” pattern created using Excel.

Step 7: Load map pattern in FILMapper
In FILMapper, click the Edit... button next to the Recipe pull-down menu if you are in theWafer
Map Tab, or Edit Recipe if you are in theMeasure Tab. Click theWafer Map tab and select Custom
for the Coordinate System. Under Custom Name, all the names of custom map files will be listed.
Here, select Custom Edit, and then click OK. In theWafer Map Tab, you should now see the “X”
pattern you created. FILMapper is capable of automatically resizing themap pattern after it has
originally been created, so there is no need to createmultiple versions of the same file. Simply
adjust the wafer size underneath theWafer Map tab.
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5.3 Creating and Editing n and k Files

Creating new n and k files
New n and k files can be created by going to Edit > Material Library… Clicking theNew button will allow
the user to define a newmaterial file. Once clicked, while theDefault Model is selected, the user can
manually enter wavelength versus n or wavelength versus k values. It is also possible to copy and paste
values into the columns if the data is available.

The user can also select Custom Model. While this is selected, clicking on theModel… button allows the
user to create n and k files using predefined mathematical models.

Once completed, clicking Save As…will save the new file as a custom material for later use.

Editing n and k files
Existing material files can be edited by going to Edit > Material Library… There, the user can load a
material file by clicking Open. Values can then be changed manually. Clicking Savewill save over the
original file for later use. Use Save As to save the edited file under a new name.

Converting Microsoft Excel files into FILMapper n and k files
For wavelength versus n or wavelength versus k data saved in Excel (*.xls) format, the data can be
directly saved as material files that can be read by FILMapper.

For .nnn and .kkk files.
For both n and k files, the data should follow the format shown below, where the wavelength values, in
units of nanometers, are in the first column, and the n or k values are in the second. Note that the
version number (cell B1) refers to version of the file. For this cell, you can use 1. Thematerial number (cell
B2) refers to what material category the file corresponds to. Thematerial categories (and their
corresponding numbers) are: Metal (1), Semiconductor (2), Dielectric (3), Other (4), and Photoresist (6).
By putting the correct value for thematerial number, the file will automatically be sorted into the correct
category when selecting thematerial in the window.

To save the file created by Microsoft Excel, go to File>Save As… For Save as Type: choose CSV (Comma
delimited) (*.csv). For n files, save the file as “FILENAME.nnn”, and for k files, save the file as
“FILENAME.kkk” (FILENAME represents the name you wish to call the file; note that quotation marks
must be used to enclose the filename in Excel to force the extension to .nnn or .kkk). The file can then be
saved to the desktop, and Imported using the File > Import > Material File option
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For .fitnk files.
The data should follow the format of shown below, where the wavelength values, in units of
nanometers, are in the first column, index of refraction (n) in the second, and extinction coefficient (k) if
present, in the third.

The first few columns of the file should be identical to the figure below the only exception being cell B3
which should contain a number describing thematerial category. Thematerial categories (and their
corresponding numbers) are: Metal (1), Semiconductor (2), Dielectric (3), Other (4), and Photoresist (6).

To save the file created by Microsoft Excel, go to File > Save As… For Save as Type: choose CSV (Comma
delimited) (*.csv). Save the file as “FILENAME.fitnk” (FILENAME represents the name you wish to call the
file; note that quotation marks must be used to enclose the filename in Excel to force the extension to
.fitnk). The file can then be saved to the desktop, and Imported using the File > Import > Material File
option
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6. Theory of Operation
This section describes how the instruments work and includes the theory themeasurements are based
on, specifics about the hardware, and more detail about the baselinemeasurement.

Measurement Theory

Thickness Measurement Details

The Baseline Measurement

6.1 Measurement Theory

Our instruments measure thin-film characteristics by either reflecting light from, or transmitting light
through the sample, and then analyzing this light over a range of wavelengths. Because of its wave-like
properties, light reflected from the top and bottom interfaces of a thin film can be in-phase so that
reflections add, or out-of-phase so that reflections subtract. Whether the reflections are in- or out-of-
phase (or somewhere in between) depends on the wavelength of the light, as well as the thickness and
properties of the film (e.g., reflections are in-phase when λ = (2*n*d)/i, where λ is the wavelength, n is the
refractive index, d is the film thickness, and i is an integer). The result is characteristic intensity oscillations
in the reflectance spectrum (see Figure below). In general, the thicker the film, themore oscillations there
are in a given wavelength range.

Example of reflectance spectrum with oscillations.

The amplitude of the oscillations is determined by the refractive index and extinction coefficient of the
films and substrate. Therefore, by analyzing the period and amplitude of these oscillations, our
instruments can determine thickness ofmultiple thin films.
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6.2 Thickness Measurement Details

Optical thin-film thickness measurements require the successful completion of two tasks: acquisition and
then analysis of an accurate reflectance spectrum. To determine film thickness, FILMapper calculates a
reflectance spectrum that matches as closely as possible themeasured spectrum. FILMapper begins with
an initial guess for what the reflectance spectrum should look like theoretically, based on the user’s input
of a film structure for the sample. Then FILMapper varies the parameters it is solving for until the
calculated reflectance spectrum matches themeasured data. Mathematically, this procedure is
complicated by the fact that as the thickness of the films in the calculation is varied there can bemany
near matches. Therefore, an approach that simply homes in on a solution by finding successively better
approximations will not work unless the starting guess for optical thickness is within approximately 1000
Å if the actual thickness.

FILMapper avoids homing in on a false solution by searching the entire acceptable thickness range to
determine the thickness that gives the best possible match between themeasured and calculated
spectra. The thickness range searched is determined by the initial guess for thickness together with the
thickness constraint. Since the time to find a solution is proportional to the range of thicknesses being
searched it is beneficial to provide an initial guess close to the thickness of the films to bemeasured.

6.3 The Baseline Measurement

The baselinemeasurement allows the FILMapper software to take into account the response inherent to
the reflectancemeasurement hardware. It does this by measuring a reflectance standard and by taking a
“dark” reading. In any optical system there aremany components whose characteristics vary with
wavelength (e.g., the output of the light source and the sensitivity of the spectrometer). However, when
reflectancemeasurements aremade, only variations in reflectance vs. wavelength due to the sample
under test are of interest. Therefore, FILMapper must perform a calibration to determine the spectral
response of the system. This is done by making a measurement of a reflectance standard that has known
reflectance characteristics. Note that it is not necessary for the reflectance standard to be the same as
the substrate upon which films to bemeasured reside. The only purpose served by the reflectance
standard is to permit calibration of the optical system. For example, it is possible to use a Si wafer as the
reflectance standard and then measure films on GaAs, InP, glass, plastic, etc.

After the referencemeasurement is made a dark reading is taken. A non-zero dark level is due to current
leakage inherent to photodiodes, which causes each photodiode in the array to slowly charge up even
when no light enters the spectrometer. Thus, in order to make an accuratemeasurement of the light
entering the spectrometer, it is necessary to subtract this “dark” current contribution. This is the
purpose of the background reading, which measures themagnitude of the dark current for a given
integration time. When a “dark” measurement is made, a spectrum is measured that represents the
signal generated by the spectrometer when a sample of zero reflectance is measured. To simulate a
sample with zero reflectance during a “dark” measurement, a specularly reflecting sample can be held at
an angle with the light source turned on, or in the case of the UV light source, the shutter may simply be
closed.
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How to Contact Us
Wewelcome suggestions from our users on ways to improve our software and hardware. Please send us
any suggestions you may have for improvements in the help file or new features you would like to see in
the software.

Wemay be reached by phone at +1-858-573-9300, by fax at +1-858-573-9400, by the Contact Us Now form
on our website, or by e-mail at support@filmetrics.com.
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7. Appendices
This section contains information on various topics as listed below:

Performance Specifications

Application Note: Silicon Nitride

Software License Agreement

7.1 Performance Specifications

F60-t-UV
F60-t-
UVX

F60-t F60-t-EXR F60-t-NIR F60-t-XT F60-t-XXT

Wavelength Range:
190-1100

nm
190-1700

nm
380-1050

nm
380-1700

nm
950-1700

nm
1440-

1690 nm
1520-1580

nm
Thickness Measurement

Range*:
5 nm-40
µm

5 nm-250
µm

20 nm-
700 µm

20 nm-
250 µm

100 nm-
250 µm

0.2 µm-
450 µm

10 µm-1
mm

Thickness Req'd to Measure n
and k*:

50 nm and up 100 nm and up
500 nm
and up

- -

Accuracy*:
The greater of 0.4%

or 1 nm
The greater of 0.4%

or 2 nm

The
greater of
0.4% or 3

nm

The greater of 0.4%
or 5 nm

Precision1: 0.1 nm 0.2 nm 1 nm
Stability2: 0.07 nm 0.12 nm 1 nm
Spot Size: Standard 1.5mm, Optional down to 20 µm 600 µm 25 µm

Light Source:
Deuterium & Tung-

sten-Halogen
Tungsten-Halogen

1550nm
SLED

Wafer Handling:
2", 3", 100mm, 150mm, 200mm, 300mm

Power Requirements:
100-240 VAC, 50-60 Hz, Vacuum

Dimensions(cm):
Measurement Station: 44LW x 35W x 38H.
Controller: 56L x 48W x 14H.



90

Weight:
Measurement Station: 23 kg (51 lbs)
Controller: 18 kg (39 lbs)

* Material dependent.
1 1σ of 100 measurements of 500 nm SiO

2
-on-Si. Average of 1σ over 20 successive days.

2 2σ of daily average of 100 measurements of 500 nm SiO
2
-on-Si over 20 successive days.

Specifications subject to change without notice.
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7.2 Application Note - Si3N4

Theoretical Underpinnings
The refractive index of a single layer film is related primarily to the depth of theminima found in the
measured reflectance. The reflectance at the interference fringeminima of a film deposited onto Si is zero
when the refractive index is near 1.97. The reflectance at the fringeminima for a film with a refractive
index of 2.00 is the same as that for a film with a refractive index of 1.94. Therefore, it can be difficult to
unambiguously determine the refractive index from a reflectancemeasurement. However, for most films
the user knows that the refractive index is either always greater than or always less than 1.97 so there is
no uncertainty. Silicon nitride is one of the few rare films whose refractive index spans this critical range.
Fortunately, there is a solution for silicon nitride that allows us to determine which of the two possible
refractive index values is correct. This is done by measuring both n and k for silicon nitride and by
realizing that silicon nitride with a refractive index larger than 1.97 has measurable absorption (non-zero
k) at wavelengths less than 420 nm. Thus, to get good results for n the widest possible wavelength range
should be used (especially going down to short wavelengths) and the user should simultaneously
measure both n and k.

Continue to Discussion of n and k Measurement.

Discussion of Si3N4 n and k Measurement
Silicon nitride is a dielectric material commonly used in semiconductor fabrication processes. The
refractive index of stoichiometric Silicon Nitride is 2.05 at 633 nm. However, in practice the refractive
index of deposited films can vary from 1.7 or less (films containing excess hydrogen or oxygen) to as high
as 2.5 or more (Si rich films). Themeasurement of n and k is complicated by the fact that this refractive
index range (1.7 to 2.5) spans a critical range for films deposited on Si substrates. In order to get an
unambiguous result for measurement of n, the structure description should be set by choosing “Si3N4
(Si Rich)” as thematerial for the silicon nitride layer. To confirm that the proper model is chosen, go to
the options tab and note that themodel displayed is “Si3N4”. If the Si3N4model is not displayed in the
nk Model list and Si3N4 is not in the list ofmodels, then newer software is required. It is important that
both n and k bemeasured simultaneously (put a check mark for n and for k in the Edit Recipe>Film
Stack dialog box). When using the Si3N4model the constraints for n and k should be set to large values
(at least 5). If the film is very thin (less than 50 nm), it may be necessary to set thematerial to “Si3N4” or
“Si3N4-thin”, instead of “Si3N4 (Si Rich)”, to get reproducible results, but this should only be used as a
last resort.

Continue to Step by Step Instructions for measuring Si3N4.

Step-by-step instructions for measuring silicon nitride on Si
1. Start FILMapper and click the Edit Recipe button.

2. Set thematerial for theMedium to “Air”.
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3. Set thematerial for Layer 1 to “Si3N4 (Si Rich)”.

4. Enter a guess for the layer thickness of the silicon nitride into the thickness box for Layer 1.

5. Put check marks in the d, n, and k check boxes for Layer 1.

6. Set the constraint for d to 75%.

7. Set the constraint for n to 5 and the constraint for k to 5.

8. Set thematerial for the Substrate to “Si”.

9. Select Grid from thickness solver options pull down menu under Thickness.

10. Go to the Analysis Options tab.

11. Make sure there is no check mark for Compensate for: > Unmodelled Back-side reflections.

12. Under Advanced Analysis Options, set the number of Iterations to “600” and set GOF greater than
to “0.999”.

13. Under Data Selection select Fixed Range and enter “From: 200” and “To: 1100”.

14. Click Save As and give the recipe a name.

15. Follow the instructions in Example B for measuring thickness and optical constants.

End User Software License
Important – Read carefully: This Agreement (“Agreement”) is a legal agreement between you (both you,
individually and your company entity) and Filmetrics, Inc. (“Licensor” or “Filmetrics”) The FILMapper
software (the “Software”) subject to this Agreement and any accompanying documentation is for your
use solely and exclusively with a device manufactured by or for Filmetrics (“Filmetrics Device”).

By downloading, installing, copying or otherwise using the Software you
expressly agree to be bound by all of the terms of this Agreement. This Agreement
is displayed for you to read prior to using the Software. If you choose not to accept, or do not agree with
all of the provisions of this Agreement, do not download, install or use the Software but, instead delete it
and, if applicable, request from the authorized Filmetrics distributor from whom you purchased the
Software, a full refund of any fees you paid for the Software.
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LICENSE
This license agreement (“license”) permits you to use one copy of the Software on any single computer.
The Software is owned by Filmetrics and is protected by United States copyright law and international
treaty provisions. Therefore, this software should be treated as any other copyrighted material except
that you may either: (1) make one copy of the Software for archival backup purposes, or (2) copy the
Software to a single hard disk in all cases, solely for use with a Filmetrics Device. If the Software is used on
a networked computer system wheremore than one computer can access the Software provisions must
bemade to insure that the number of concurrently executing copies of the Software cannot exceed the
number of licenses.
You may transfer the Software and all rights under this Agreement to another party together with a copy
of this Agreement if the other party agrees to accept the terms and conditions of this Agreement. If you
transfer the Software, you must at the same time either transfer all copies (including any prior versions)
in any form to the same party or destroy any copies not transferred.

RESTRICTIONS
You may not use, disclose, distribute, copy, modify, rent, lease, loan, resell, network or transfer the
Software, or any copy, modification or merged portion thereof, in whole or in part, to any third party
except as expressly specified in this Agreement. You agree to provide reasonable security precautions to
prevent unauthorized access to or use of the Software as proscribed herein. You agree not to decompile,
reverse engineer, disassemble or otherwise reduce the Software to a human perceivable form and you
agree not to permit any person or entity to do so. You shall not remove, alter, cover, or obscure any
confidentiality, trade secret, proprietary, or copyright notices, trademarks, proprietary, patent, or other
identifying marks or designs from any component of the Software, and you shall reproduce and include
in all copies of the Software the copyright notice(s) and proprietary legend(s) of Filmetrics and its
licensors as they appear in the Software.

SOURCE CODE
If source code to the Software was supplied to you, then you may modify and use that source code in
place of the executable version of the Software, but no further rights to distribution or use are granted.
You acknowledge that you have no obligation to createmodifications of the Software source code
(“Licensed Revisions”) nor to disclose such Licensed Revisions to Licensor. You acknowledge that by
making Licensed Revisions, the underlying Softwaremay not be compatible with any future versions of
the Software that Licensor might offer (in Licensor’s sole discretion), and you agree to assume such risk.
Continuing for the term of this Agreement, you hereby grant to Licensor and its affiliates a limited non-
transferable, non-exclusive, worldwide, fully paid-up, royalty-free license (with the right to sublicense) to
make, use, sell, offer to sell, import, export and otherwise distribute such Licensed Revisions under any
of your patents that, if not authorized, would be directly or indirectly infringed by themanufacture, use,
sale, offer to sell or other distribution of the Licensed Revisions. You may not combine or distribute the
Software or Licensed Revisions with Open Source Software (as defined below) or with software developed
using Open Source Software (e.g., tools) in a manner that subjects the Software and Licensed Revisions
or any portion thereof to any license obligations of such Open Source Software. "Open Source Software"
means any software licensed under terms requiring that other software combined or distributed with
such software: (i) be disclosed or distributed in source code form; (ii) be licensed on terms inconsistent
with the terms of this Agreement.
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TERM
This Agreement is effective until terminated. You may terminate it at any time by destroying the Software
together with all copies, modifications and merged portions in any form. This Agreement will
immediately and automatically terminate without notice if you fail to comply with any term or condition
of this Agreement. You agree upon termination to cease using and promptly destroy the Software and
Licensed Revisions together with all copies in any form.

GOVERNMENT LICENSEE
If you are acquiring the Software on behalf of any unit or agency of the United States Government, the
following provisions apply:
The Government acknowledges the licensor’s representation that the Software and its documentation
were developed at private expense and no part of them is in the public domain. The Software is a
"commercial item," as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of "commercial
computer software" and "commercial computer software documentation," as such terms are used in 48
C.F.R. 12.212 (SEPT 1995). All U.S. Government licensees and end users acquire the Software with only
those rights set forth herein.

EXPORT LAW ASSURANCES
You acknowledge and agree that the Software is subject to restrictions and controls imposed by the
United States Export Administration Act (the “Act”) and the regulations thereunder. You agree and certify
that neither the Software nor any direct product thereof is being or will be acquired, shipped, transferred
or re-exported, directly or indirectly, into any country prohibited by the Act and the regulations
thereunder or will be used for any purpose prohibited by the same.

DISCLAIMER OF WARRANTIES. EXCEPT TO THE EXTENT OF ANY LIMITEDWARRANTY PROVIDED BY THE
SELLER, THE SOFTWARE IS FURNISHED "AS-IS", AND TO THEMAXIMUM EXTENT PERMITTED BY
APPLICABLE LAW, LICENSORMAKES NOWARRANTY, EXPRESS, IMPLIED OR STATUTORY, INCLUDING ANY
IMPLIEDWARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, TITLE OR NON-
INFRINGEMENT OF ANY THIRD PARTY PATENTS, COPYRIGHTS, TRADE SECRETS OR OTHER INTELLECTUAL
PROPERTY RIGHTS. LICENSOR DOES NOTWARRANT THAT THE SOFTWARE IS FREE FROM BUGS, VIRUSES,
ERRORS OR OTHER PROGRAM LIMITATIONS. YOU AGREE TO USE YOUR INDEPENDENT JUDGMENT IN
DEVELOPING YOUR PRODUCTS. YOU ACKNOWLEDGE AND AGREE THAT LICENSOR IS UNDER NO
OBLIGATION TO INSTALL, MAINTAINOR SUPPORT THE SOFTWARE, OR PROVIDE UPGRADES OR NEW
RELEASES THEREOF, SHOULD LICENSOR PROVIDE ANY ASSISTANCE LICENSORMAKES NOWARRANTIES
WITH RESPECT TO ANY SUCH ASSISTANCE. YOU ASSUME THE ENTIRE RISK ARISING OUT OF THE USE OR
PERFORMANCE OF THE SOFTWARE AND ANY SYSTEMS OR PRODUCTS YOUDESIGNUSING THE
SOFTWARE.
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EXCLUSION OF DAMAGES. TO THEMAXIMUM EXTENT PERMITTED BY LAW, IN NO EVENT SHALL
LICENSOR, OR ITS EMPLOYEES, OFFICERS, DIRECTORS, AGENTS, AFFILIATES OR ANY APPLICABLE
LICENSOR (TOGETHER THE “REPRESENTATIVES”), BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL,
PUNITIVE OR CONSEQUENTIAL DAMAGES, INCLUDING BUT NOT LIMITED TO, DAMAGES FOR ANY LOSS OF
USE, LOSS OF TIME, INCONVENIENCE, COMMERCIAL LOSS OR LOST PROFITS, SAVINGS OR REVENUES,
HOWEVER CAUSED, ONANY THEORY OF LIABILITY, IN CONNECTIONWITH OR ARISING OUT OF THIS
AGREEMENT, THE SOFTWARE, THE LICENSED REVISIONS EVEN IF LICENSOR REPRESENTATIVES HAVE BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF A REMEDY SET FORTH HEREIN IS FOUND
TO HAVE FAILED OF ITS ESSENTIAL PURPOSE. IN NO EVENT SHALL LICENSOR’S AGGREGATE LIABILITY
UNDER THIS AGREEMENT EXCEED USD $500.00 OR THE FEES PAID BY YOU FOR THE SOFTWARE UNDER
THIS AGREEMENT. THE LIMITATIONS OF DAMAGES SET FORTH ABOVE ARE FUNDAMENTAL ELEMENTS OF
THE BASIS OF THE BARGAIN BETWEEN LICENSOR AND YOU.

GENERAL
This Agreement will be governed by the laws of the State of California, U.S.A. without regard to its conflict
of law provisions. If a court of competent jurisdiction finds any provision of the Agreement to be
unenforceable, that provision will be enforced to themaximum extent possible to effectuate the intent of
the parties, and the remainder of the Agreement will continue in full force and effect. Failure of Licensor
to enforce any terms of this Agreement shall not be deemed or considered a waiver of future
enforcement of that or any other term in this Agreement and no consent, waiver, or excuse by Licensor,
express or implied, constitutes a subsequent consent, waiver or excuse. You acknowledge that you have
read this Agreement, understand it and agree to be bound by its terms and conditions. You further agree
that it is the complete and exclusive statement of the agreement between us which supersedes any
proposal or prior agreement, oral or written, and any other communications between us in relation to
the subject matter of this Agreement. This Agreement shall bemodified only by a written instrument
signed by a duly authorized representative of Licensor, or from time to time, Licensor may modify or
change the terms and conditions of this Agreement and supersede the terms of any prior version of this
Agreement, in connection with any supplemental, different or new terms that might apply to an update
or upgrade of the Softwaremade available by Licensor, in Licensor’s sole discretion. Your continued use
of the Software after you download and accept the new, additional or changed terms applicable to such
update or upgrade will indicate your agreement to the change to this Agreement. You may not sell,
assign, transfer, delegate, convey, pledge, encumber or otherwise dispose of, by operation of law or
otherwise, the Software, Licensed Revisions or this Agreement, or any rights or obligations hereunder.
Licensor may assign this Agreement, and any or all of its rights and duties under this Agreement, without
prior notice to you or your consent. You hereby warrant and represent that you have obtained all
authorization and other applicable consents required empowering you to enter into this Agreement.
Rights and obligations under this Agreement which by their nature should survive, will remain in effect
after termination or expiration of this Agreement.


